summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2023-08-25 00:25:18 +0300
committerEd Tanous <ed@tanous.net>2023-09-25 20:50:15 +0300
commit11e8f60df2fbe1ceafdf886132bd93d112a726bf (patch)
treea5a393b6ec81a04d7c021737ca71ba58af1482eb /meson.build
parentb25644a1ae3bbf00ddea91ad494be959cb2632c8 (diff)
downloadbmcweb-11e8f60df2fbe1ceafdf886132bd93d112a726bf.tar.xz
Clean up vm CredentialPipe
This code is needlessly complicated for what it does. Even with the intent, which is secure buffer cleanup, it's trivial to encase all this into a single class that accepts the strings by rvalue reference, then cleans them up afterward. Doing this also cleans up a potential lifetime problem, where if the unix socket returned immediately, it would've invalidated the buffers that were being sent. It also moves to async_write, instead of async_write_some. The former could in theory fail if the socket blocks (unlikely in this scenario) but it's good to handle anyway. Tested: Need some help here. There's no backend for this, so we might just have to rely on inspection. Change-Id: I9032d458f8eb7a0689bee575aae611641bacee26 Signed-off-by: Ed Tanous <edtanous@google.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9f22f23370..4aa7c330a9 100644
--- a/meson.build
+++ b/meson.build
@@ -389,6 +389,7 @@ srcfiles_unittest = files(
'test/include/http_utility_test.cpp',
'test/include/human_sort_test.cpp',
'test/include/async_resolve_test.cpp',
+ 'test/include/credential_pipe_test.cpp',
'test/include/ibm/configfile_test.cpp',
'test/include/ibm/lock_test.cpp',
'test/include/multipart_test.cpp',