summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarson Labrado <clabrado@google.com>2023-10-18 03:02:10 +0300
committerCarson Labrado <clabrado@google.com>2023-10-18 04:36:37 +0300
commit2b5b4dae1925b4b0884b5ed2be0a34dff851372c (patch)
tree1bb29b4b6b9743231a6b4f3476eaf9aa63ef8419 /meson.build
parent5ebb9d33056cbffd8ec0affc49ac9e439e0c4c9e (diff)
downloadbmcweb-2b5b4dae1925b4b0884b5ed2be0a34dff851372c.tar.xz
Fix local compile
The update to boost 1.83.0 was breaking for our build process if boost 1.83.0 was not already installed. Update our meson file to correctly pull in all of the required boost libraries. Tested: I was able to locally build bmcweb without having previously installed any boost libraries. All unit tests also passed. meson buildlocal && ninja -C buildlocal test Signed-off-by: Carson Labrado <clabrado@google.com> Change-Id: I1d00ef561fed7e3ba799969a112ee58b6578ce32
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build38
1 files changed, 34 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 401b5964d3..e2754c563f 100644
--- a/meson.build
+++ b/meson.build
@@ -307,19 +307,49 @@ if not nlohmann_json.found()
endif
bmcweb_dependencies += nlohmann_json
-boost = dependency('boost', modules: ['url'], version : '>=1.83.0', required : false, include_type: 'system')
+boost = dependency(
+ 'boost',
+ modules: [
+ 'asio',
+ 'beast',
+ 'callable_traits',
+ 'headers',
+ 'process',
+ 'type_index',
+ 'url',
+ 'uuid'
+ ],
+ version : '>=1.83.0',
+ required : false,
+ include_type: 'system'
+)
if boost.found()
bmcweb_dependencies += [boost]
else
cmake = import('cmake')
opt = cmake.subproject_options()
opt.add_cmake_defines({
- 'BOOST_INCLUDE_LIBRARIES': 'url'
+ 'BOOST_INCLUDE_LIBRARIES': 'asio;beast;callable_traits;headers;process;type_index;url;uuid'
})
boost = cmake.subproject('boost', required: true, options: opt)
- boost_url = boost.dependency('boost_url').as_system()
+ boost_asio = boost.dependency('boost_asio').as_system()
+ boost_beast = boost.dependency('boost_beast').as_system()
+ boost_callable_traits = boost.dependency('boost_callable_traits').as_system()
boost_headers = boost.dependency('boost_headers').as_system()
- bmcweb_dependencies += [boost_url, boost_headers]
+ boost_process = boost.dependency('boost_process').as_system()
+ boost_type_index = boost.dependency('boost_type_index').as_system()
+ boost_url = boost.dependency('boost_url').as_system()
+ boost_uuid = boost.dependency('boost_uuid').as_system()
+ bmcweb_dependencies += [
+ boost_asio,
+ boost_beast,
+ boost_callable_traits,
+ boost_headers,
+ boost_process,
+ boost_type_index,
+ boost_url,
+ boost_uuid
+ ]
endif
if get_option('tests').enabled()