summaryrefslogtreecommitdiff
path: root/config/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'config/meson.build')
-rw-r--r--config/meson.build49
1 files changed, 29 insertions, 20 deletions
diff --git a/config/meson.build b/config/meson.build
index 7328820a6b..21da40e077 100644
--- a/config/meson.build
+++ b/config/meson.build
@@ -9,21 +9,26 @@ conf_data.set10('BMCWEB_INSECURE_ENABLE_QUERY_PARAMS', enable_redfish_query.allo
# enable_redfish_aggregation = get_option('redfish-aggregation')
# conf_data.set10('BMCWEB_ENABLE_REDFISH_AGGREGATION', enable_redfish_aggregation.allowed())
insecure_push_style_notification = get_option('insecure-push-style-notification')
-conf_data.set10('BMCWEB_INSECURE_ENABLE_HTTP_PUSH_STYLE_EVENTING', insecure_push_style_notification.allowed())
+conf_data.set10(
+ 'BMCWEB_INSECURE_ENABLE_HTTP_PUSH_STYLE_EVENTING',
+ insecure_push_style_notification.allowed(),
+)
conf_data.set('MESON_INSTALL_PREFIX', get_option('prefix'))
conf_data.set('HTTPS_PORT', get_option('https_port'))
enable_multi_host = get_option('experimental-redfish-multi-computer-system')
conf_data.set10('BMCWEB_ENABLE_MULTI_HOST', enable_multi_host.allowed())
enable_http2 = get_option('experimental-http2')
conf_data.set10('BMCWEB_ENABLE_HTTP2', enable_http2.allowed())
-conf_data.set10('BMCWEB_ENABLE_MTLS_COMMON_NAME_PARSING_META', get_option('mutual-tls-common-name-parsing') == 'meta')
-
+conf_data.set10(
+ 'BMCWEB_ENABLE_MTLS_COMMON_NAME_PARSING_META',
+ get_option('mutual-tls-common-name-parsing') == 'meta',
+)
# Logging level
loglvlopt = get_option('bmcweb-logging')
if get_option('buildtype').startswith('debug') and loglvlopt == 'disabled'
- # Override logging level as 'debug' if 'bmcweb-logging' is set as 'dsiabled'
- loglvlopt = 'debug'
+ # Override logging level as 'debug' if 'bmcweb-logging' is set as 'dsiabled'
+ loglvlopt = 'debug'
endif
loglvlopt = loglvlopt.to_upper()
conf_data.set('BMCWEB_LOGGING_LEVEL', loglvlopt)
@@ -33,27 +38,31 @@ conf_h_dep = declare_dependency(
sources: configure_file(
input: 'bmcweb_config.h.in',
output: 'bmcweb_config.h',
- configuration: conf_data
- )
+ configuration: conf_data,
+ ),
)
# Configure and install systemd unit files
-configure_file(input : 'bmcweb.socket.in',
- output : 'bmcweb.socket',
- install_dir: systemd_system_unit_dir,
- configuration: conf_data,
- install : true)
+configure_file(
+ input: 'bmcweb.socket.in',
+ output: 'bmcweb.socket',
+ install_dir: systemd_system_unit_dir,
+ configuration: conf_data,
+ install: true,
+)
-configure_file(input : 'bmcweb.service.in',
- output : 'bmcweb.service',
- install_dir: systemd_system_unit_dir,
- configuration: conf_data,
- install : true)
+configure_file(
+ input: 'bmcweb.service.in',
+ output: 'bmcweb.service',
+ install_dir: systemd_system_unit_dir,
+ configuration: conf_data,
+ install: true,
+)
# Copy pam-webserver to etc/pam.d
install_data(
- 'pam-webserver',
- install_dir: '/etc/pam.d/',
- rename: 'webserver',
+ 'pam-webserver',
+ install_dir: '/etc/pam.d/',
+ rename: 'webserver',
)