summaryrefslogtreecommitdiff
path: root/meta-ingrasys
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-02-17 16:30:57 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-02-18 21:41:12 +0300
commitd5c716dc3add128301ec4ba8ebb21bb6eb7856fd (patch)
treeec3dcdc3ab942a2beac6b9207f3a8506bfaa34af /meta-ingrasys
parent18a6b18c34b9c651b96fa3fb5be956aee1604db9 (diff)
downloadopenbmc-d5c716dc3add128301ec4ba8ebb21bb6eb7856fd.tar.xz
treewide: fix append/remove directives
As mentioned by I970e06ca6f9d0a9792af122eb25da1bb9a06f058, append and remove directives with '+=' are no longer valid Yocto syntax and raise a warning. See https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n40 One interesting caveat has to do with the difference between "append" and "+=". foo:append = "a" foo:append = "b" Results in `foo = "ab"`, but foo += "a" foo += "b" Results in `foo = "a b"`. When `:append +=` is used it has behavior like the `+=` operator. Therefore, in some cases we need to insert additional whitespace after the `:append = "` to ensure concatenation behaves as expected. I've manually reviewed the results to ensure there is no ill side-effects from an additional space potentially being added. Fix up the entire tree with the following one-liner (and similar for `remove`): git ls-files -- ':!:poky/**' ':!:meta-security/**' \ ':!:meta-raspberrypi/**' ':!:meta-openembedded/**' \ | grep "\.bb" | xargs grep -l ":append.*+=" \ | xargs sed -i 's/:append\(.*\)+=\([^"]*\)" */:append\1=\2" /' or ... | xargs grep -l ":remove.*+=" \ | xargs sed -i "s/:remove\(.*\)+=/:remove\1=/" Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Iea6235e7c76e252f4d473652957c2925f6b8845a
Diffstat (limited to 'meta-ingrasys')
-rw-r--r--meta-ingrasys/meta-zaius/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-ingrasys/meta-zaius/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ingrasys/meta-zaius/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index ce9c697de4..9cfccaedb9 100644
--- a/meta-ingrasys/meta-zaius/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-ingrasys/meta-zaius/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -7,5 +7,5 @@ INSTFMT = "phosphor-gpio-presence@{0}.service"
TGT = "multi-user.target"
FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
-SYSTEMD_LINK:${PN}-presence:append:zaius += "${@compose_list(d, 'FMT', 'PCIE_CARD_E2B_INSTANCE')}"
-SYSTEMD_ENVIRONMENT_FILE:${PN}-presence:append:zaius += "obmc/gpio/phosphor-pcie-card-e2b.conf"
+SYSTEMD_LINK:${PN}-presence:append:zaius = " ${@compose_list(d, 'FMT', 'PCIE_CARD_E2B_INSTANCE')}"
+SYSTEMD_ENVIRONMENT_FILE:${PN}-presence:append:zaius = " obmc/gpio/phosphor-pcie-card-e2b.conf"