summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-ruby/recipes-devtools/ruby/bundler_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-08-17 23:04:38 +0300
committerPatrick Williams <patrick@stwcx.xyz>2016-08-22 19:43:32 +0300
commitb48b7b4109868a8c0ddda090992e936e821c7ea6 (patch)
tree696be8ea782f2548c0f63bb0188f4c8d3eeed681 /import-layers/meta-openembedded/meta-ruby/recipes-devtools/ruby/bundler_git.bb
parentd849ec78de728ef9a2d383b92ccfeabf40f8f1d0 (diff)
downloadopenbmc-b48b7b4109868a8c0ddda090992e936e821c7ea6.tar.xz
Squashed 'import-layers/meta-openembedded/' content from commit 247b126
Change-Id: I40827e9ce5fba63f1cca2a0be44976ae8383b4c0 git-subtree-dir: import-layers/meta-openembedded git-subtree-split: 247b1267bbe95719cd4877d2d3cfbaf2a2f4865a Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'import-layers/meta-openembedded/meta-ruby/recipes-devtools/ruby/bundler_git.bb')
-rw-r--r--import-layers/meta-openembedded/meta-ruby/recipes-devtools/ruby/bundler_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/import-layers/meta-openembedded/meta-ruby/recipes-devtools/ruby/bundler_git.bb b/import-layers/meta-openembedded/meta-ruby/recipes-devtools/ruby/bundler_git.bb
new file mode 100644
index 000000000..31e72e562
--- /dev/null
+++ b/import-layers/meta-openembedded/meta-ruby/recipes-devtools/ruby/bundler_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Makes sure Ruby applications run the same code on every machine."
+DESCRIPTION = "Bundler makes sure Ruby applications run the same code \
+on every machine. It does this by managing the gems that the \
+application depends on. Given a list of gems, it can automatically \
+download and install those gems, as well as any other gems needed by \
+the gems that are listed. Before installing gems, it checks the \
+versions of every gem to make sure that they are compatible, and can \
+all be loaded at the same time. After the gems have been installed, \
+Bundler can help you update some or all of them when new versions \
+become available. Finally, it records the exact versions that have \
+been installed, so that others can install the exact same gems."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=196bb963e601609817d7e9ac9a64a867"
+
+SRCREV = "06dc8472b9142fd6aaefff780d6d252c20dc2a04"
+
+BRANCH = "1-9-stable"
+PV = "1.9.4"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = " \
+ git://github.com/bundler/bundler.git;branch=${BRANCH} \
+ "
+
+inherit ruby
+
+RDEPENDS_${PN} = "git"
+
+BBCLASSEXTEND = "native"