summaryrefslogtreecommitdiff
path: root/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
diff options
context:
space:
mode:
authorKonstantin Aladyshev <aladyshev22@gmail.com>2021-04-19 11:37:54 +0300
committerKonstantin Aladyshev <aladyshev22@gmail.com>2021-04-21 16:57:54 +0300
commita953aa6a9eec526ef80e58fb7323d926d98764f4 (patch)
tree4180604181da5d8655b0eb94cbbfbd0f0bcb8377 /meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
parent993d4560ef4971ae4b2a205b3ed7cf587762d90e (diff)
downloadopenbmc-a953aa6a9eec526ef80e58fb7323d926d98764f4.tar.xz
meta-amd: FPGA Register Dump Utility Script
Usage: fpgardu.sh Uses i2c bus 2 to access FPGA registers and display the data Signed-off-by: Paul Erb <paul.erb@amd.com> Signed-off-by: Supreeth Venkatesh <supreeth.venkatesh@amd.com> Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com> Change-Id: I2608eb48fa4cb3ef2d8837bc22a8efe3dc339d37
Diffstat (limited to 'meta-amd/recipes-amd/amd-fpga/amd-fpga.bb')
-rw-r--r--meta-amd/recipes-amd/amd-fpga/amd-fpga.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb b/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
new file mode 100644
index 000000000..3fcaeaa91
--- /dev/null
+++ b/meta-amd/recipes-amd/amd-fpga/amd-fpga.bb
@@ -0,0 +1,18 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}:"
+SUMMARY = "AMD Ethanolx FPGA Register Dump Utility"
+DESCRIPTION = "AMD Ethanolx FPGA Register Dump Utility"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5e24678b8d0883d9dfa9e9473069ddd2"
+
+RDEPENDS_${PN} = "bash"
+SRCREV = "${AUTOREV}"
+SRC_URI = "file://fpgardu.sh"
+SRC_URI += "file://LICENSE"
+
+S = "${WORKDIR}/"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/fpgardu.sh ${D}${bindir}/
+}