summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
diff options
context:
space:
mode:
authordheerajpdsk <p.dheeraj.srujan.kumar@intel.com>2022-05-06 02:48:05 +0300
committerGitHub <noreply@github.com>2022-05-06 02:48:05 +0300
commitca8d06bc610af08c2d3efc487aa9519989b743e6 (patch)
treec557da2136640a8ce48439f19fe5f7071faffeca /meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
parent7cf0c1cd0ce835d1833509b7b911e8a97380278b (diff)
parent18f97faa411078b95d042d207f5fff32bc8ece1d (diff)
downloadopenbmc-ca8d06bc610af08c2d3efc487aa9519989b743e6.tar.xz
Merge pull request #80 from Intel-BMC/updateHEAD1-0.91intel
Update
Diffstat (limited to 'meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb')
-rw-r--r--meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
new file mode 100644
index 000000000..1b5a119b1
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+S = "${WORKDIR}"
+
+SRC_URI = "file://inventory-cleanup.yaml"
+
+do_install() {
+ install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
+}
+
+FILES:${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"