summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-common
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-09-20 13:47:54 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-09-20 13:51:11 +0300
commit3c212f087b0b50c49a59d60200259b1adced25dd (patch)
tree316c80682401b28e83e228426ac59a46ca610bdb /meta-ampere/meta-common
parente1bcaf31c4d98d7fc7941092ebdf66ef9bc81ed2 (diff)
downloadopenbmc-3c212f087b0b50c49a59d60200259b1adced25dd.tar.xz
meta-ampere: mtjade: set MAC Address from FruDevice
FruDevice service is always running no matter if entity-manager is used or not. It scans for all FRU EEPROMs, parse and store information into dbus. This commit changes to get BMC MAC Address from FruDevice data instead of ipmi-fru-parser. Tested: 1. Clear environment in u-boot, boot BMC to Linux and check if the eth1addr variable is set with value from FRU. 2. Change BMC MAC address from FRU's Board Extra. Reboot BMC and check if the eth1addr variable is set with new BMC MAC Address Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I99b5d46c8a22b98402f749cdebd1c0aad3d6daf0
Diffstat (limited to 'meta-ampere/meta-common')
-rw-r--r--meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update.bb26
-rw-r--r--meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update/ampere_update_mac.service12
-rw-r--r--meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update/ampere_update_mac.sh43
3 files changed, 0 insertions, 81 deletions
diff --git a/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update.bb b/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update.bb
deleted file mode 100644
index b6ddfad80..000000000
--- a/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "Ampere Computing LLC Update MAC Address from FRU Inventory Information"
-DESCRIPTION = "Update MAC Address from FRU Inventory Information for Ampere systems"
-PR = "r1"
-
-LICENSE = "Apache-2.0"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit systemd
-inherit obmc-phosphor-systemd
-
-DEPENDS = "systemd"
-RDEPENDS:${PN} = "bash"
-
-FILESEXTRAPATHS:append := "${THISDIR}/${PN}:"
-
-SRC_URI += " \
- file://ampere_update_mac.sh \
- "
-
-SYSTEMD_SERVICE:${PN} = "ampere_update_mac.service"
-
-do_install:append() {
- install -d ${D}/${sbindir}
- install -m 755 ${WORKDIR}/ampere_update_mac.sh ${D}/${sbindir}
-}
diff --git a/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update/ampere_update_mac.service b/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update/ampere_update_mac.service
deleted file mode 100644
index 86f7a0346..000000000
--- a/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update/ampere_update_mac.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Updating MAC Address Service From FRU inventory
-After=xyz.openbmc_project.Inventory.Manager.service
-
-[Service]
-ExecStart=/usr/sbin/ampere_update_mac.sh
-SyslogIdentifier=ampere_update_mac.sh
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update/ampere_update_mac.sh b/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update/ampere_update_mac.sh
deleted file mode 100644
index 5dbdde771..000000000
--- a/meta-ampere/meta-common/recipes-ac01/mac/ampere-mac-update/ampere_update_mac.sh
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/bash
-#
-# This script is used to get the MAC Address from FRU Inventory information
-
-ETHERNET_INTERFACE="eth0"
-ENV_ETH="eth1addr"
-ENV_MAC_ADDR=`fw_printenv`
-
-# Check if BMC MAC address is exported
-if [[ $ENV_MAC_ADDR =~ $ENV_ETH ]]; then
- echo "WARNING: BMC MAC address already exist!"
- exit 0
-fi
-
-# Read FRU Board Custom Field 1 to get the MAC address
-CUSTOM_FIELD_1=`busctl get-property xyz.openbmc_project.Inventory.Manager /xyz/openbmc_project/inventory/system/chassis/motherboard xyz.openbmc_project.Inventory.Item.NetworkInterface MACAddress`
-MAC_ADDR=`echo $CUSTOM_FIELD_1 | cut -d "\"" -f 2`
-
-# Check if BMC MAC address is exported
-if [ -z "${MAC_ADDR}" ]; then
- echo "ERROR: No BMC MAC address is detected from FRU Inventory information!"
- # Return 1 so that systemd knows the service failed to start
- exit 1
-fi
-
-# Request to update the MAC address
-fw_setenv ${ENV_ETH} ${MAC_ADDR}
-
-if [[ $? -ne 0 ]]; then
- echo "ERROR: Fail to set MAC address to ${ENV_ETH}"
- exit 1
-fi
-
-# Request to restart the service
-ifconfig ${ETHERNET_INTERFACE} down
-ifconfig ${ETHERNET_INTERFACE} hw ether ${MAC_ADDR}
-if [[ $? -ne 0 ]]; then
- echo "ERROR: Can not update MAC ADDR to ${ETHERNET_INTERFACE}"
- exit 1
-fi
-ifconfig ${ETHERNET_INTERFACE} up
-
-echo "Successfully update the MAC address ${MAC_ADDR} to ${ENV_ETH} and ${ETHERNET_INTERFACE}"