summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/conf
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-12 13:21:36 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-13 11:00:42 +0300
commitca3e1d9f86212282ca59f384055497eb0d156d49 (patch)
tree83e2db0f50a87dfab90432a5c02e11d91ce2f6f3 /meta-ampere/meta-jade/conf
parent5037330368f3e01c45dc0e42b39246afa2c6c44a (diff)
downloadopenbmc-ca3e1d9f86212282ca59f384055497eb0d156d49.tar.xz
meta-ampere: fix compilation error with latest Yocto
Make the following changes to fix compilation errors: 1. Add honister to LAYERSERIES_COMPAT 2. Increase CONF_VERSION to 2. 3. Fix mistake on previous change on Yocto syntax update. Tested: 1. Compile OpenBMC for Mt.Jade without error. Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I5ac3f568d776109955759fab78844b1d38a51af1
Diffstat (limited to 'meta-ampere/meta-jade/conf')
-rw-r--r--meta-ampere/meta-jade/conf/layer.conf2
-rw-r--r--meta-ampere/meta-jade/conf/local.conf.sample6
-rw-r--r--meta-ampere/meta-jade/conf/machine/mtjade.conf1
3 files changed, 5 insertions, 4 deletions
diff --git a/meta-ampere/meta-jade/conf/layer.conf b/meta-ampere/meta-jade/conf/layer.conf
index e8abd6921..7b5a07f3d 100644
--- a/meta-ampere/meta-jade/conf/layer.conf
+++ b/meta-ampere/meta-jade/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "jade-layer"
BBFILE_PATTERN_jade-layer := "^${LAYERDIR}/"
-LAYERSERIES_COMPAT_jade-layer = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_jade-layer = "gatesgarth hardknott honister"
diff --git a/meta-ampere/meta-jade/conf/local.conf.sample b/meta-ampere/meta-jade/conf/local.conf.sample
index 914da7119..1d3c71471 100644
--- a/meta-ampere/meta-jade/conf/local.conf.sample
+++ b/meta-ampere/meta-jade/conf/local.conf.sample
@@ -117,7 +117,7 @@ SANITY_TESTED_DISTROS:append ?= " *"
# There are other application targets that can be used here too, see
# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
# We default to enabling the debugging tweaks.
-EXTRA_IMAGE_FEATURES = "debug-tweaks"
+EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
#
# Additional image features
@@ -169,7 +169,7 @@ PATCHRESOLVE = "noop"
# files and damages the build in ways which may not be easily recoverable.
# It's necessary to monitor /tmp, if there is no space left the build will fail
# with very exotic errors.
-BB_DISKMON_DIRS = "\
+BB_DISKMON_DIRS ??= "\
STOPTASKS,${TMPDIR},1G,100K \
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
@@ -212,4 +212,4 @@ BB_DISKMON_DIRS = "\
# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
# track the version of this file when it was generated. This can safely be ignored if
# this doesn't mean anything to you.
-CONF_VERSION = "1"
+CONF_VERSION = "2"
diff --git a/meta-ampere/meta-jade/conf/machine/mtjade.conf b/meta-ampere/meta-jade/conf/machine/mtjade.conf
index 67e852b44..2c948df6d 100644
--- a/meta-ampere/meta-jade/conf/machine/mtjade.conf
+++ b/meta-ampere/meta-jade/conf/machine/mtjade.conf
@@ -19,6 +19,7 @@ OBMC_MACHINE_FEATURES += "\
obmc-phosphor-chassis-mgmt \
obmc-phosphor-flash-mgmt \
obmc-chassis-state-mgmt \
+ obmc-host-state-mgmt \
obmc-bmc-state-mgmt \
"