summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-01-07 10:16:50 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-02-01 16:44:47 +0300
commit25254b72534874a19e28baa00446247765ccdbde (patch)
tree679be069166258eb40271c5e0981ceaeb14a03a0 /meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
parent189431e93efb0dfd7efa69c40fead8bd11a9b01a (diff)
downloadopenbmc-25254b72534874a19e28baa00446247765ccdbde.tar.xz
meta-ampere: mtjade: Add Host firmware update support
Enable flash_bios feature and configure to use backend script to flash UEFI firmware via Redfish, WebUI and Rest. Tested: 1. Flash UEFI firmware via WebUI. 2. Flash UEFI firmware via Redfish UpdateService 3. Flash UEFI firmware via Rest interface. Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I772e6a409414e374ed01e72e3c69985d0b413cb5
Diffstat (limited to 'meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb')
-rw-r--r--meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb b/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
new file mode 100644
index 000000000..9b2840134
--- /dev/null
+++ b/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
@@ -0,0 +1,23 @@
+
+SUMMARY = "Ampere Computing LLC Flashing Utilities"
+DESCRIPTION = "Application to support flashing utilities on Ampere platforms"
+PR = "r0"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+RDEPENDS_${PN} = "bash"
+DEPENDS = "zlib"
+
+SRC_URI += "\
+ file://ampere_flash_bios.sh \
+ "
+
+S = "${WORKDIR}"
+ROOT = "${STAGING_DIR_TARGET}"
+
+LDFLAGS += "-L ${ROOT}/usr/lib/ -lz "
+
+do_install_append() {
+ install -d ${D}/usr/sbin
+ install -m 0755 ${S}/ampere_flash_bios.sh ${D}/${sbindir}/ampere_flash_bios.sh
+}