summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-07 08:09:50 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-07 09:46:45 +0300
commitfa1aa4d9bba2b95f28828ad7c473b63cb66037e4 (patch)
treec7c6ac7cf6031883c14ecdabec68108e4688feee /meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
parent76a963a5f1eb2bb5adcd7fb0f81089d5e06aca1a (diff)
downloadopenbmc-fa1aa4d9bba2b95f28828ad7c473b63cb66037e4.tar.xz
meta-ampere: Cleanup for Yocto override syntax change
Run convert-overrides.py meta-ampere and update missing changes as below: - Change all _mtjade to :mtjade - Change all _${PN} to :${PN} Tested: 1. Check compilation without problem. 2. Check basic functions like switch UART mux, power control. Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I42038b2a98ed1951d6c770bdf49f5fc440f8163e
Diffstat (limited to 'meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb')
-rw-r--r--meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb b/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
index 9b2840134..241070c4e 100644
--- a/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
+++ b/meta-ampere/meta-jade/recipes-ampere/flash/ampere-flash-utils.bb
@@ -5,7 +5,7 @@ PR = "r0"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-RDEPENDS_${PN} = "bash"
+RDEPENDS:${PN} = "bash"
DEPENDS = "zlib"
SRC_URI += "\
@@ -17,7 +17,7 @@ ROOT = "${STAGING_DIR_TARGET}"
LDFLAGS += "-L ${ROOT}/usr/lib/ -lz "
-do_install_append() {
+do_install:append() {
install -d ${D}/usr/sbin
install -m 0755 ${S}/ampere_flash_bios.sh ${D}/${sbindir}/ampere_flash_bios.sh
}