summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:17:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-02 16:19:25 +0300
commite83c22094b7e4970c96bcee273ab08d05bbc0a30 (patch)
tree80cb87a34afb07b7d375b534bb5df68468c2b5a6 /meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb
parentd97cf9b9ef84cdad2f357164e36b76619e7dc379 (diff)
downloadopenbmc-e83c22094b7e4970c96bcee273ab08d05bbc0a30.tar.xz
meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override syntax, including the SYSTEMD_ variables. Change our systemd.bbclass to do the same for consistency and perform a tree-wide variable replacement. Spot checked by building bletchley and witherspoon and checking some of the SYSTEMD_LINK directives on installed packages under qemu. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb b/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb
index cde625f5b..79bfb726e 100644
--- a/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb
+++ b/meta-ampere/meta-jade/recipes-phosphor/gpio/host-gpio-handling.bb
@@ -10,7 +10,7 @@ RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
OBMC_HOST_ACK_MONITOR_INSTANCES = "reboot_ack shutdown_ack"
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/reboot_ack \
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/reboot_ack \
obmc/gpio/shutdown_ack \
"
@@ -20,4 +20,4 @@ TGT = "multi-user.target"
FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
SYSTEMD_SERVICE:${PN} += "ampere-host-shutdown-ack@.service"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_ACK_MONITOR_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_ACK_MONITOR_INSTANCES')}"