summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-12 13:21:36 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-13 11:00:42 +0300
commitca3e1d9f86212282ca59f384055497eb0d156d49 (patch)
tree83e2db0f50a87dfab90432a5c02e11d91ce2f6f3 /meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
parent5037330368f3e01c45dc0e42b39246afa2c6c44a (diff)
downloadopenbmc-ca3e1d9f86212282ca59f384055497eb0d156d49.tar.xz
meta-ampere: fix compilation error with latest Yocto
Make the following changes to fix compilation errors: 1. Add honister to LAYERSERIES_COMPAT 2. Increase CONF_VERSION to 2. 3. Fix mistake on previous change on Yocto syntax update. Tested: 1. Compile OpenBMC for Mt.Jade without error. Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I5ac3f568d776109955759fab78844b1d38a51af1
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb b/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
index c1a616a9c..8e57c3ea2 100644
--- a/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
+++ b/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
@@ -16,7 +16,7 @@ do_install() {
${D}${bindir}/toggle_identify_led.sh
}
-SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/id_button"
+SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/id_button"
ID_BUTTON_SERVICE = "id_button"
@@ -26,4 +26,4 @@ TGT = "multi-user.target"
FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
SYSTEMD_SERVICE:${PN} += "id-button-pressed.service"
-SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"