summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
diff options
context:
space:
mode:
authorThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-07 08:09:50 +0300
committerThang Q. Nguyen <thang@os.amperecomputing.com>2021-08-07 09:46:45 +0300
commitfa1aa4d9bba2b95f28828ad7c473b63cb66037e4 (patch)
treec7c6ac7cf6031883c14ecdabec68108e4688feee /meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
parent76a963a5f1eb2bb5adcd7fb0f81089d5e06aca1a (diff)
downloadopenbmc-fa1aa4d9bba2b95f28828ad7c473b63cb66037e4.tar.xz
meta-ampere: Cleanup for Yocto override syntax change
Run convert-overrides.py meta-ampere and update missing changes as below: - Change all _mtjade to :mtjade - Change all _${PN} to :${PN} Tested: 1. Check compilation without problem. 2. Check basic functions like switch UART mux, power control. Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com> Change-Id: I42038b2a98ed1951d6c770bdf49f5fc440f8163e
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb b/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
index c19cdee18..c1a616a9c 100644
--- a/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
+++ b/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
SRC_URI += "file://toggle_identify_led.sh"
@@ -16,7 +16,7 @@ do_install() {
${D}${bindir}/toggle_identify_led.sh
}
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/id_button"
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/id_button"
ID_BUTTON_SERVICE = "id_button"
@@ -25,5 +25,5 @@ INSTFMT = "phosphor-gpio-monitor@{0}.service"
TGT = "multi-user.target"
FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "id-button-pressed.service"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"
+SYSTEMD_SERVICE:${PN} += "id-button-pressed.service"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"