summaryrefslogtreecommitdiff
path: root/meta-ampere/meta-jade/recipes-phosphor/gpio/psu-hotswap-reset.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:17:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-02 16:19:25 +0300
commite83c22094b7e4970c96bcee273ab08d05bbc0a30 (patch)
tree80cb87a34afb07b7d375b534bb5df68468c2b5a6 /meta-ampere/meta-jade/recipes-phosphor/gpio/psu-hotswap-reset.bb
parentd97cf9b9ef84cdad2f357164e36b76619e7dc379 (diff)
downloadopenbmc-e83c22094b7e4970c96bcee273ab08d05bbc0a30.tar.xz
meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override syntax, including the SYSTEMD_ variables. Change our systemd.bbclass to do the same for consistency and perform a tree-wide variable replacement. Spot checked by building bletchley and witherspoon and checking some of the SYSTEMD_LINK directives on installed packages under qemu. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
Diffstat (limited to 'meta-ampere/meta-jade/recipes-phosphor/gpio/psu-hotswap-reset.bb')
-rw-r--r--meta-ampere/meta-jade/recipes-phosphor/gpio/psu-hotswap-reset.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-ampere/meta-jade/recipes-phosphor/gpio/psu-hotswap-reset.bb b/meta-ampere/meta-jade/recipes-phosphor/gpio/psu-hotswap-reset.bb
index 2ca18a0be..839c6d4d1 100644
--- a/meta-ampere/meta-jade/recipes-phosphor/gpio/psu-hotswap-reset.bb
+++ b/meta-ampere/meta-jade/recipes-phosphor/gpio/psu-hotswap-reset.bb
@@ -13,7 +13,7 @@ OBMC_PSU_MONITOR_INSTANCES = "PSU1_B25 PSU2_B25"
# Copies config file having arguments for psu
# via GPIO assertion
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/PSU1_B25 \
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/PSU1_B25 \
obmc/gpio/PSU2_B25 \
"
SYSTEMD_SERVICE:${PN} ?= "psu1_hotswap_reset.service psu2_hotswap_reset.service"
@@ -29,4 +29,4 @@ GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{0}.service"
TGT = "multi-user.target"
PSU_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:${TGT}.requires/${GPIO_MONITOR_TGTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'PSU_MONITOR_FMT', 'OBMC_PSU_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'PSU_MONITOR_FMT', 'OBMC_PSU_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"