summaryrefslogtreecommitdiff
path: root/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
diff options
context:
space:
mode:
authorzhanghaicheng <zhanghch05@inspur.com>2021-12-23 04:44:26 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-12-30 18:45:46 +0300
commit851a10e54604704eabed9f565f29e98627521fc6 (patch)
treec11544ceb16da867dd8255985ad79669b76cb5d1 /meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
parent0ee50bdd6b0ba3cd7da17fe0f6ccce2312521d0f (diff)
downloadopenbmc-851a10e54604704eabed9f565f29e98627521fc6.tar.xz
Fix the config error of u-boot-env
When using 64M flash, the config of u-boot CONFIG_ENV_SIZE and CONFIG_ENV_OFFSET is wrong. The config file fw_env.config is wrong, too. Modify them according to the 64M flash dts file. Before correcting these errors, when we used setenv to set environment variables in u-boot, we could not use fw_printenv to get them. The reverse is also the same. Because they set different offset and size. Tested: 1. Use commands in u-boot: setenv test value saveenv After BMC starts, use fw_printenv can get "test=value" 2. Use the command to change the value of "test" fw_setenv test v We can get "test=v" in u-boot by printenv. Signed-off-by: zhanghaicheng <zhanghch05@inspur.com> Change-Id: I9eccf6abe743253b6f8c344a8b8648e68ab52019
Diffstat (limited to 'meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
index 90e120677..2708ae081 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-fw-utils-aspeed-sdk_2019.04.bb
@@ -1,4 +1,5 @@
require u-boot-common-aspeed-sdk_${PV}.inc
+require conf/machine/distro/include/uboot-distrovars.inc
SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
DEPENDS += "mtd-utils"
@@ -8,9 +9,11 @@ RPROVIDES:${PN} += "u-boot-fw-utils"
SRC_URI += "file://fw_env_ast2600_nor.config"
SRC_URI += "file://fw_env_ast2600_mmc.config"
+SRC_URI += "file://fw_env_flash_64M_nor.config"
ENV_CONFIG_FILE = "fw_env_ast2600_nor.config"
ENV_CONFIG_FILE:df-phosphor-mmc = "fw_env_ast2600_mmc.config"
+ENV_CONFIG_FILE:uboot-flash-65536 = "fw_env_flash_64M_nor.config"
INSANE_SKIP:${PN} = "already-stripped"
EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'