summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-05-04 22:10:14 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-05-04 22:10:14 +0300
commit794d26fa53ad7e8cb54a3a5773436b1d8e813f35 (patch)
tree92940f7842138b00efea3b42140093a3bf39b81b /meta-aspeed
parent235618c7396902842906bc3a8c90a3320aeeaeba (diff)
parenta6da583e088a2e9462d5330555a704402eff74a9 (diff)
downloadopenbmc-794d26fa53ad7e8cb54a3a5773436b1d8e813f35.tar.xz
Merge tag 'wht-0.53' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/conf/layer.conf2
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb2
-rw-r--r--meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g4/defconfig1
-rw-r--r--meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g5/defconfig1
-rw-r--r--meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g6/defconfig1
-rw-r--r--meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb4
6 files changed, 7 insertions, 4 deletions
diff --git a/meta-aspeed/conf/layer.conf b/meta-aspeed/conf/layer.conf
index 9741d26b2..cba3b77da 100644
--- a/meta-aspeed/conf/layer.conf
+++ b/meta-aspeed/conf/layer.conf
@@ -7,4 +7,4 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "aspeed-layer"
BBFILE_PATTERN_aspeed-layer := "^${LAYERDIR}/"
LAYERVERSION_aspeed-layer = "1"
-LAYERSERIES_COMPAT_aspeed-layer = "warrior zeus"
+LAYERSERIES_COMPAT_aspeed-layer = "warrior zeus dunfell"
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
index 491068520..78c352f27 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
@@ -1,6 +1,6 @@
require u-boot-common-aspeed-sdk_${PV}.inc
-UBOOT_MAKE_TARGET ?= "u-boot.${UBOOT_SUFFIX} DEVICE_TREE=${UBOOT_DEVICETREE}"
+UBOOT_MAKE_TARGET ?= "DEVICE_TREE=${UBOOT_DEVICETREE}"
require recipes-bsp/u-boot/u-boot.inc
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g4/defconfig b/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g4/defconfig
index f19fb3932..d39aa1865 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g4/defconfig
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g4/defconfig
@@ -229,6 +229,7 @@ CONFIG_PANIC_ON_OOPS=y
CONFIG_PANIC_TIMEOUT=-1
# CONFIG_SCHED_DEBUG is not set
CONFIG_SCHED_STACK_END_CHECK=y
+CONFIG_DEBUG_LIST=y
CONFIG_FUNCTION_TRACER=y
# CONFIG_RUNTIME_TESTING_MENU is not set
CONFIG_DEBUG_WX=y
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g5/defconfig b/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g5/defconfig
index 45da2b24b..1c6c0f649 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g5/defconfig
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g5/defconfig
@@ -252,6 +252,7 @@ CONFIG_PANIC_ON_OOPS=y
CONFIG_PANIC_TIMEOUT=-1
# CONFIG_SCHED_DEBUG is not set
CONFIG_SCHED_STACK_END_CHECK=y
+CONFIG_DEBUG_LIST=y
CONFIG_FUNCTION_TRACER=y
# CONFIG_RUNTIME_TESTING_MENU is not set
CONFIG_DEBUG_WX=y
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g6/defconfig b/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g6/defconfig
index 8f21ec507..a7d1d7d44 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g6/defconfig
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed/aspeed-g6/defconfig
@@ -285,6 +285,7 @@ CONFIG_PANIC_ON_OOPS=y
CONFIG_PANIC_TIMEOUT=-1
# CONFIG_SCHED_DEBUG is not set
CONFIG_SCHED_STACK_END_CHECK=y
+CONFIG_DEBUG_LIST=y
CONFIG_FUNCTION_TRACER=y
# CONFIG_RUNTIME_TESTING_MENU is not set
CONFIG_DEBUG_WX=y
diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
index ad443aac5..28d939903 100644
--- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
+++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb
@@ -1,6 +1,6 @@
KBRANCH ?= "dev-5.4"
-LINUX_VERSION ?= "5.4.26"
+LINUX_VERSION ?= "5.4.32"
-SRCREV="1440369fcdef35f5b30dde253032188fd9611af8"
+SRCREV="2cf49560af20199920858cb91e3b7b138e54f597"
require linux-aspeed.inc