summaryrefslogtreecommitdiff
path: root/meta-aspeed
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2021-08-25 09:16:26 +0300
committerAndrew Jeffery <andrew@aj.id.au>2021-08-30 09:52:26 +0300
commit50e2234e380c6deca02bd98a1643a95cd8d0dfa7 (patch)
tree962abd5bbded8dd9072ec3c83fac08fa11382742 /meta-aspeed
parentfc192996873a3cc63d7fd1128626c0a72797783e (diff)
downloadopenbmc-50e2234e380c6deca02bd98a1643a95cd8d0dfa7.tar.xz
meta-aspeed: u-boot-aspeed-sdk: Ensure SOCSEC_SIGN defaults are set
Include the socsec-sign class after the conditional assignments to ensure the values we might assign are considered by the functions of socsec-sign. Without this, u-boot-aspeed-sdk do_deploy logs show: ``` DEBUG: Executing python function sstate_task_prefunc DEBUG: Python function sstate_task_prefunc finished DEBUG: Executing shell function do_deploy Copying u-boot-nodtb binary... Warning: Invalid socsec signing key - SPL verified boot won't be available ``` Adjusting the location of the include gives: ``` DEBUG: Executing python function sstate_task_prefunc DEBUG: Python function sstate_task_prefunc finished DEBUG: Executing shell function do_deploy Copying u-boot-nodtb binary... check header PASS Found PEM header at position 381 check integrity PASS ``` Change-Id: I15cac4c315a6ceaeb69b0c02ba0b7d05e54f6e15 Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Diffstat (limited to 'meta-aspeed')
-rw-r--r--meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
index a142c1731..6f2d979bc 100644
--- a/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
+++ b/meta-aspeed/recipes-bsp/u-boot/u-boot-aspeed-sdk_2019.04.bb
@@ -3,7 +3,6 @@ require u-boot-common-aspeed-sdk_${PV}.inc
UBOOT_MAKE_TARGET ?= "DEVICE_TREE=${UBOOT_DEVICETREE}"
require u-boot-aspeed.inc
-inherit socsec-sign
PROVIDES += "u-boot"
DEPENDS += "bc-native dtc-native"
@@ -18,6 +17,8 @@ SOCSEC_SIGN_KEY ?= "${WORKDIR}/rsa_oem_dss_key.pem"
SOCSEC_SIGN_ALGO ?= "RSA4096_SHA512"
SOCSEC_SIGN_EXTRA_OPTS ?= "--stack_intersects_verification_region=false"
+inherit socsec-sign
+
UBOOT_ENV_SIZE:df-phosphor-mmc = "0x10000"
UBOOT_ENV:df-phosphor-mmc = "u-boot-env"
UBOOT_ENV_SUFFIX:df-phosphor-mmc = "bin"