summaryrefslogtreecommitdiff
path: root/meta-bytedance/meta-g220a/recipes-phosphor/sensors
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-10-04 22:42:48 +0300
committerGitHub <noreply@github.com>2021-10-04 22:42:48 +0300
commit0c9e31989c615598b5d042ffab385606660c93c0 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-bytedance/meta-g220a/recipes-phosphor/sensors
parent04cd92067d2481643df5010cb39b2134b648cf4d (diff)
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
downloadopenbmc-0c9e31989c615598b5d042ffab385606660c93c0.tar.xz
Merge pull request #72 from Intel-BMC/update2021-0.751-0.75
Update
Diffstat (limited to 'meta-bytedance/meta-g220a/recipes-phosphor/sensors')
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/sensors/phosphor-virtual-sensor/virtual_sensor_config.json396
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend8
2 files changed, 404 insertions, 0 deletions
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/sensors/phosphor-virtual-sensor/virtual_sensor_config.json b/meta-bytedance/meta-g220a/recipes-phosphor/sensors/phosphor-virtual-sensor/virtual_sensor_config.json
new file mode 100644
index 000000000..dec59d5fd
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/sensors/phosphor-virtual-sensor/virtual_sensor_config.json
@@ -0,0 +1,396 @@
+[
+ {
+ "Desc":
+ {
+ "Name": "total_power",
+ "SensorType": "power"
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "PSU0_Input_Power",
+ "SensorType": "power"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "PSU1_Input_Power",
+ "SensorType": "power"
+ }
+ }
+ ]
+ },
+ "Expression": "T0 + T1"
+ },
+ {
+ "Desc":
+ {
+ "Name": "P0_DIMM_VR_Pwr",
+ "SensorType": "power"
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "CPU0_DIMM_VR_0_Input_Power",
+ "SensorType": "power"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "CPU0_DIMM_VR_1_Input_Power",
+ "SensorType": "power"
+ }
+ }
+ ]
+ },
+ "Expression": "T0 + T1"
+ },
+ {
+ "Desc":
+ {
+ "Name": "P1_DIMM_VR_Pwr",
+ "SensorType": "power"
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "CPU1_DIMM_VR_0_Input_Power",
+ "SensorType": "power"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "CPU1_DIMM_VR_1_Input_Power",
+ "SensorType": "power"
+ }
+ }
+ ]
+ },
+ "Expression": "T0 + T1"
+ },
+ {
+ "Desc":
+ {
+ "Name": "CPU0_VR_Pwr",
+ "SensorType": "power"
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "CPU0_VR_0_Input_Power",
+ "SensorType": "power"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "CPU0_VR_1_Input_Power",
+ "SensorType": "power"
+ }
+ },
+ {
+ "ParamName": "T2",
+ "Desc":
+ {
+ "Name": "CPU0_VR_2_Input_Power",
+ "SensorType": "power"
+ }
+ }
+ ]
+ },
+ "Expression": "T0 + T1 + T2"
+ },
+ {
+ "Desc":
+ {
+ "Name": "CPU1_VR_Pwr",
+ "SensorType": "power"
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "CPU1_VR_0_Input_Power",
+ "SensorType": "power"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "CPU1_VR_1_Input_Power",
+ "SensorType": "power"
+ }
+ },
+ {
+ "ParamName": "T2",
+ "Desc":
+ {
+ "Name": "CPU1_VR_2_Input_Power",
+ "SensorType": "power"
+ }
+ }
+ ]
+ },
+ "Expression": "T0 + T1 + T2"
+ },
+ {
+ "Desc":
+ {
+ "Name": "P0_DIMM_VR_Temp",
+ "SensorType": "temperature"
+ },
+ "Threshold" :
+ {
+ "CriticalHigh": 125,
+ "WarningHigh": 105
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "CPU0_DIMM_VR_0_Temperature",
+ "SensorType": "temperature"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "CPU0_DIMM_VR_1_Temperature",
+ "SensorType": "temperature"
+ }
+ }
+ ]
+ },
+ "Expression": "max(T0, T1)"
+ },
+ {
+ "Desc":
+ {
+ "Name": "P1_DIMM_VR_Temp",
+ "SensorType": "temperature"
+ },
+ "Threshold" :
+ {
+ "CriticalHigh": 125,
+ "WarningHigh": 105
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "CPU1_DIMM_VR_0_Temperature",
+ "SensorType": "temperature"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "CPU1_DIMM_VR_1_Temperature",
+ "SensorType": "temperature"
+ }
+ }
+ ]
+ },
+ "Expression": "max(T0, T1)"
+ },
+ {
+ "Desc":
+ {
+ "Name": "CPU0_VR_Temp",
+ "SensorType": "temperature"
+ },
+ "Threshold" :
+ {
+ "CriticalHigh": 125,
+ "WarningHigh": 105
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "CPU0_VR_0_Temperature",
+ "SensorType": "temperature"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "CPU0_VR_1_Temperature",
+ "SensorType": "temperature"
+ }
+ },
+ {
+ "ParamName": "T2",
+ "Desc":
+ {
+ "Name": "CPU0_VR_2_Temperature",
+ "SensorType": "temperature"
+ }
+ }
+ ]
+ },
+ "Expression": "max(T0, T1, T2)"
+ },
+ {
+ "Desc":
+ {
+ "Name": "CPU1_VR_Temp",
+ "SensorType": "temperature"
+ },
+ "Threshold" :
+ {
+ "CriticalHigh": 125,
+ "WarningHigh": 105
+ },
+ "Associations":
+ [
+ [
+ "chassis",
+ "all_sensors",
+ "/xyz/openbmc_project/inventory/system/board/G220A"
+ ]
+ ],
+ "Params":
+ {
+ "DbusParam":
+ [
+ {
+ "ParamName": "T0",
+ "Desc":
+ {
+ "Name": "CPU1_VR_0_Temperature",
+ "SensorType": "temperature"
+ }
+ },
+ {
+ "ParamName": "T1",
+ "Desc":
+ {
+ "Name": "CPU1_VR_1_Temperature",
+ "SensorType": "temperature"
+ }
+ },
+ {
+ "ParamName": "T2",
+ "Desc":
+ {
+ "Name": "CPU1_VR_2_Temperature",
+ "SensorType": "temperature"
+ }
+ }
+ ]
+ },
+ "Expression": "max(T0, T1, T2)"
+ }
+]
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend b/meta-bytedance/meta-g220a/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
new file mode 100644
index 000000000..9c853669f
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/sensors/phosphor-virtual-sensor_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI += " \
+ file://virtual_sensor_config.json \
+"
+
+do_install:append() {
+ install -m 0644 -D ${WORKDIR}/virtual_sensor_config.json ${D}${datadir}/phosphor-virtual-sensor/
+}