summaryrefslogtreecommitdiff
path: root/meta-bytedance/meta-g220a/recipes-phosphor
diff options
context:
space:
mode:
authorLotus Xu <xuxiaohan@bytrdance.com>2020-10-20 11:28:30 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-31 19:41:06 +0300
commit530f068ba17f2e03c2a939eaebff75cd72c356b3 (patch)
tree1cc01089876d8712d23a6f38772ed6eaa5a54857 /meta-bytedance/meta-g220a/recipes-phosphor
parentf1258543dcd63821158b858b9260570c0ca810fe (diff)
downloadopenbmc-530f068ba17f2e03c2a939eaebff75cd72c356b3.tar.xz
bytedance: g220a: Enable ipmb
Tested : we can see /dev/ipmb-4 on g220a Use `busctl call xyz.openbmc_project.Ipmi.Channel.Ipmb \ "/xyz/openbmc_project/Ipmi/Channel/Ipmb" org.openbmc.Ipmb \ sendRequest yyyyay 0x01 0x0a 0x00 0x48 0` to get ME time correctly (From meta-bytedance rev: 58c6841aee1bd93c1070401ce7ca589367b8e6d0) Signed-off-by: Lotus Xu <xuxiaohan@bytrdance.com> Change-Id: Ic45173405ec9cd1806b5caa7a5081b6ed0d8fc3e Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-bytedance/meta-g220a/recipes-phosphor')
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-ipmi-ipmb/ipmb-channels.json10
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend8
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-ipmi-ipmb/ipmb-channels.json b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-ipmi-ipmb/ipmb-channels.json
new file mode 100644
index 000000000..3d901aee0
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-ipmi-ipmb/ipmb-channels.json
@@ -0,0 +1,10 @@
+{
+ "channels": [
+ {
+ "type": "me",
+ "slave-path": "/dev/ipmb-4",
+ "bmc-addr": 32,
+ "remote-addr": 44
+ }
+ ]
+}
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
new file mode 100644
index 000000000..03c685d1d
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-ipmi-ipmb_%.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append = " file://ipmb-channels.json"
+
+do_install_append(){
+ install -m 0644 -D ${WORKDIR}/ipmb-channels.json \
+ ${D}/usr/share/ipmbbridge/
+}