summaryrefslogtreecommitdiff
path: root/meta-bytedance
diff options
context:
space:
mode:
authorLotus Xu <xuxiaohan@bytedance.com>2020-10-27 10:17:40 +0300
committerLei YU <yulei.sh@bytedance.com>2021-07-02 09:58:18 +0300
commit9eaaa78e295d4e21c5eb8bcd137876eb767a100d (patch)
tree41a685fb42b1b161a9399e818d02b827513b493c /meta-bytedance
parentb1aa759e502a39e82b8b634820e5caf265ad2271 (diff)
downloadopenbmc-9eaaa78e295d4e21c5eb8bcd137876eb767a100d.tar.xz
bytedance: g220a: Enable phosphor-node-manager-proxy
Tested: Verify the CPU_Power and Memory_Power sensors are OK. Signed-off-by: Lotus Xu <xuxiaohan@bytedance.com> Change-Id: I13fde13adc4062d5586167e411c129a986e3ad76
Diffstat (limited to 'meta-bytedance')
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json6
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend10
-rw-r--r--meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy_git.bb19
3 files changed, 30 insertions, 5 deletions
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json b/meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json
index ae008da53..03a5d2aa3 100644
--- a/meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/configuration/entity-manager/g220a_baseboard.json
@@ -908,6 +908,10 @@
"Name": "Host/BMC Shared NIC",
"Type": "NIC"
},
+ {
+ "Name": "Node Manager Sensor",
+ "Type": "NMSensor"
+ },
{
"Address": "0x70",
"Bus": 3,
@@ -2516,4 +2520,4 @@
"AssetTag": "$PRODUCT_ASSET_TAG"
},
"xyz.openbmc_project.Inventory.Item.System": {}
-} \ No newline at end of file
+}
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend
index e38c2721b..3059e809a 100644
--- a/meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -1,4 +1,6 @@
-OBMC_IMAGE_EXTRA_INSTALL_append_g220a = " webui-vue \
- me-time-sync \
- static-mac-addr \
- "
+OBMC_IMAGE_EXTRA_INSTALL_append_g220a = " \
+ webui-vue \
+ me-time-sync \
+ static-mac-addr \
+ phosphor-node-manager-proxy \
+"
diff --git a/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy_git.bb b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy_git.bb
new file mode 100644
index 000000000..c1db3a825
--- /dev/null
+++ b/meta-bytedance/meta-g220a/recipes-phosphor/ipmi/phosphor-node-manager-proxy_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Node Manager Proxy"
+DESCRIPTION = "The Node Manager Proxy provides a simple interface for communicating \
+with Management Engine via IPMB"
+
+SRC_URI = "git://github.com/Intel-BMC/node-manager;protocol=ssh"
+SRCREV = "23590b428ea26e0ed4b8225015471b962e3b3704"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SYSTEMD_SERVICE_${PN} = "node-manager-proxy.service"
+
+DEPENDS = "sdbusplus \
+ phosphor-logging \
+ boost"
+
+S = "${WORKDIR}/git/"
+inherit cmake systemd