summaryrefslogtreecommitdiff
path: root/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor
diff options
context:
space:
mode:
authorAlexander Hedges <ahedges@ethz.ch>2018-09-27 14:34:03 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-04 18:19:55 +0300
commit951fe704aa74b84b2914c3132a5c74617bfe9b83 (patch)
treedb9eba540d68bb85619fa6c32a106e7d8b3bf16d /meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor
parent34261d61da43014259ea8e0a251bd250cf1fe5ee (diff)
downloadopenbmc-951fe704aa74b84b2914c3132a5c74617bfe9b83.tar.xz
Add support for Enclustra Mars ZX3 board as a BMC
This adds preliminary support for the Enclustra Mars ZX3 using the upstream meta-xilinx layer. In order to get it to compile this removes the phosphor-gpio-keys feature even though it could theoretically be supported. (From meta-evb rev: 07837e0d7d62497302c114008d27e0a808106ca2) Change-Id: Ie02c329864d2c981dbe245a16e0e9858b37d6aee Signed-off-by: Alexander Hedges <ahedges@ethz.ch> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor')
-rw-r--r--meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config-native.bb17
-rw-r--r--meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config/led.yaml37
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config-native.bb b/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config-native.bb
new file mode 100644
index 000000000..01b58da39
--- /dev/null
+++ b/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config-native.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Phosphor LED Group Management for Enclustra Mars ZX3"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Copies example led layout yaml file
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
diff --git a/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config/led.yaml b/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config/led.yaml
new file mode 100644
index 000000000..38eb7697f
--- /dev/null
+++ b/meta-evb/meta-evb-enclustra/meta-evb-zx3-pm3/recipes-phosphor/leds/evb-zx3-pm3-led-manager-config/led.yaml
@@ -0,0 +1,37 @@
+enclosure_identify:
+ led1:
+ Action: 'Blink'
+ DutyOn: 20
+ Period: 100
+
+bmc_booted:
+ led2:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+power_on:
+ led3:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 1000
+
+enclosure_fault:
+ led3:
+ Action: 'Blink'
+ DutyOn: 50
+ Period: 30
+
+lamp_test:
+ led1:
+ Action: 'Blink'
+ DutyOn: 20
+ Period: 50
+ led2:
+ Action: 'Blink'
+ DutyOn: 20
+ Period: 100
+ led3:
+ Action: 'Blink'
+ DutyOn: 20
+ Period: 150