summaryrefslogtreecommitdiff
path: root/meta-facebook
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-12-05 23:27:58 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-12-05 23:27:58 +0300
commitccd6cab15aedd223a42dfdb110ab2d71d8a87141 (patch)
tree2050b16c5978dbf1268ea0f1a65d15026ec25831 /meta-facebook
parent6f65bb40d3e8b7fe978698488c2ea93f077bfcd6 (diff)
parent6dbb316ab9052d4dbf158377e1ffe36f205d5477 (diff)
downloadopenbmc-ccd6cab15aedd223a42dfdb110ab2d71d8a87141.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-facebook')
-rw-r--r--meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf8
-rwxr-xr-xmeta-facebook/meta-tiogapass/recipes-fbtp/ipmi/fb-ipmi-oem_git.bb2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-phosphor/console/obmc-console/obmc-console.conf2
-rw-r--r--meta-facebook/meta-tiogapass/recipes-phosphor/console/obmc-console_%.bbappend2
4 files changed, 10 insertions, 4 deletions
diff --git a/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf b/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
index fa4c016b2..9c7a39ae6 100644
--- a/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
+++ b/meta-facebook/meta-tiogapass/conf/machine/tiogapass.conf
@@ -6,19 +6,21 @@ UBOOT_MACHINE = "ast_g5_ncsi_config"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
+SERIAL_CONSOLES = "57600;ttyS4"
+
OBMC_MACHINE_FEATURES += "\
obmc-phosphor-fan-mgmt \
obmc-phosphor-chassis-mgmt \
obmc-phosphor-flash-mgmt \
obmc-host-ipmi \
- obmc-host-ctl \
obmc-host-state-mgmt \
obmc-chassis-state-mgmt \
obmc-bmc-state-mgmt \
"
-PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= "obmc-op-control-host"
+PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= ""
PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-fb-apps"
PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = "phosphor-ipmi-kcs"
FLASH_SIZE = "32768"
VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
-
+VIRTUAL-RUNTIME_obmc-host-state-manager = "x86-power-control"
+VIRTUAL-RUNTIME_obmc-chassis-state-manager = "x86-power-control"
diff --git a/meta-facebook/meta-tiogapass/recipes-fbtp/ipmi/fb-ipmi-oem_git.bb b/meta-facebook/meta-tiogapass/recipes-fbtp/ipmi/fb-ipmi-oem_git.bb
index 1601b16f6..47025ff55 100755
--- a/meta-facebook/meta-tiogapass/recipes-fbtp/ipmi/fb-ipmi-oem_git.bb
+++ b/meta-facebook/meta-tiogapass/recipes-fbtp/ipmi/fb-ipmi-oem_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
SRC_URI = "git://github.com/openbmc/fb-ipmi-oem"
-SRCREV = "1744cb3adedb262302df60d7beb3feb55f89f474"
+SRCREV = "38183d667099c2a5291f19e6c359c247751667ef"
S = "${WORKDIR}/git"
PV = "0.1+git${SRCPV}"
diff --git a/meta-facebook/meta-tiogapass/recipes-phosphor/console/obmc-console/obmc-console.conf b/meta-facebook/meta-tiogapass/recipes-phosphor/console/obmc-console/obmc-console.conf
new file mode 100644
index 000000000..94f1dff85
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-phosphor/console/obmc-console/obmc-console.conf
@@ -0,0 +1,2 @@
+local-tty = ttyS2
+baud = 57600
diff --git a/meta-facebook/meta-tiogapass/recipes-phosphor/console/obmc-console_%.bbappend b/meta-facebook/meta-tiogapass/recipes-phosphor/console/obmc-console_%.bbappend
new file mode 100644
index 000000000..24b52d731
--- /dev/null
+++ b/meta-facebook/meta-tiogapass/recipes-phosphor/console/obmc-console_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend_tiogapass := "${THISDIR}/${PN}:"
+OBMC_CONSOLE_HOST_TTY = "ttyS2"