summaryrefslogtreecommitdiff
path: root/meta-google/recipes-core
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-07-30 00:16:52 +0300
commitbb6a14e2f317abf60677c6ad8de9c33d5760bf36 (patch)
tree00457d3677e86437cec25fd7dab6c4513a53b1a4 /meta-google/recipes-core
parentdefdca82c107f46e980c84bffb1b2c1263522fa0 (diff)
parentcf6fd27dbd8e2d1b507f8c3752b85801b2c6ef57 (diff)
downloadopenbmc-bb6a14e2f317abf60677c6ad8de9c33d5760bf36.tar.xz
Merge tag '0.63' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-google/recipes-core')
-rw-r--r--meta-google/recipes-core/os-release/os-release.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-google/recipes-core/os-release/os-release.bbappend b/meta-google/recipes-core/os-release/os-release.bbappend
new file mode 100644
index 000000000..ec6d64fcf
--- /dev/null
+++ b/meta-google/recipes-core/os-release/os-release.bbappend
@@ -0,0 +1,10 @@
+python() {
+ # Instead of using BB_ENV_EXTRAWHITE, we can get info from the
+ # shell environment this way.
+ origenv = d.getVar("BB_ORIGENV", False)
+ memo = origenv.getVar("BUILD_MEMO", False)
+ if memo:
+ d.setVar("BUILD_MEMO", memo)
+}
+
+OS_RELEASE_FIELDS_append = " BUILD_MEMO"