summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/acpi-power-state-daemon
diff options
context:
space:
mode:
authorBrandon Kim <brandonkim@google.com>2021-03-09 08:44:23 +0300
committerBrandon Kim <brandonkim@google.com>2021-03-09 11:23:22 +0300
commitcb27e7330da067b7d0d70a7672e49c1ead07ce29 (patch)
treed112218c542a037980176e1118da4c89ffdf1af8 /meta-google/recipes-google/acpi-power-state-daemon
parent35264c8e84abff3fa41979792855443a3f7f7a6d (diff)
downloadopenbmc-cb27e7330da067b7d0d70a7672e49c1ead07ce29.tar.xz
meta-google: acpi-power-state-daemon: Import from gBMC
Initial recipes-google/acpi-power-state-daemon from gBMC Google-Bug-Id: 182214245 Upstream: 311f7935ef5633e5da9599d75a01cf561cd00306 Signed-off-by: Brandon Kim <brandonkim@google.com> Change-Id: Ide5a16f2a65317c2c9f753eb4fef7d5f01abe27d
Diffstat (limited to 'meta-google/recipes-google/acpi-power-state-daemon')
-rw-r--r--meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb b/meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb
new file mode 100644
index 000000000..bf26a8c07
--- /dev/null
+++ b/meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "ACPI Power/Sleep state daemon to allow host state events"
+DESCRIPTION = "ACPI Power/Sleep state daemon to allow host state events"
+HOMEPAGE = "http://github.com/openbmc/google-misc"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI += "git://github.com/openbmc/google-misc"
+SRCREV = "15fe169d1fbdd510bb9cfc9bb725baf0613350ff"
+S = "${WORKDIR}/git/acpi-power-state-daemon"
+
+inherit meson
+inherit pkgconfig
+inherit systemd
+
+DEPENDS += " \
+ phosphor-dbus-interfaces \
+ sdbusplus \
+ systemd \
+ "
+
+SYSTEMD_SERVICE_${PN} = " \
+ acpi-power-state.service \
+ host-s0-state.target \
+ host-s5-state.target \
+ "