summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/default-ca-dev/default-ca-dev.bb
diff options
context:
space:
mode:
authorAlan Kuo <Alan_Kuo@quantatw.com>2020-12-23 04:51:14 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-01-08 22:13:56 +0300
commitc239b6f869f0b56d7a24f48f4b8e1107dab724c7 (patch)
tree675747ed4a6ec12fa2a5379786448aa551225a30 /meta-google/recipes-google/default-ca-dev/default-ca-dev.bb
parent16941fc1b0fb92826ad88b3d55c40c9896756bd0 (diff)
downloadopenbmc-c239b6f869f0b56d7a24f48f4b8e1107dab724c7.tar.xz
meta-google: recipes-google: Add static dev CA and specific user
Add Feature: 1. default-users: Add static User "Megapede" without password 2. default-ca-dev: Add static dev CA Note: 1. CA PATH: meta-google\recipes-google\default-ca-dev\default-ca-dev\certs\authority All CAs under the folder will be encapsulated into the firmware image (From meta-google rev: 0f2aba07b911c194e8ae5323040a80e55f761fd2) Signed-off-by: Alan Kuo <Alan_Kuo@quantatw.com> Change-Id: I862e74445e67662e11c06bdfd20606656f5043f7 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-google/recipes-google/default-ca-dev/default-ca-dev.bb')
-rw-r--r--meta-google/recipes-google/default-ca-dev/default-ca-dev.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-google/recipes-google/default-ca-dev/default-ca-dev.bb b/meta-google/recipes-google/default-ca-dev/default-ca-dev.bb
new file mode 100644
index 000000000..ecbb71267
--- /dev/null
+++ b/meta-google/recipes-google/default-ca-dev/default-ca-dev.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Add dev default CA"
+DESCRIPTION = "Add dev default CA"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI += "file://certs/authority/"
+
+FILES_${PN} = "${sysconfdir}/ssl/certs/authority/*"
+
+do_install(){
+ install -d ${D}${sysconfdir}/ssl/certs/authority
+ install -m 0644 -D ${WORKDIR}/certs/authority/* \
+ ${D}${sysconfdir}/ssl/certs/authority
+}