summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/host-power-ctrl/gpio-host-pwr_git.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-10-04 22:42:48 +0300
committerGitHub <noreply@github.com>2021-10-04 22:42:48 +0300
commit0c9e31989c615598b5d042ffab385606660c93c0 (patch)
tree8019999b0ca042482e5193d6cabc06220c71d776 /meta-google/recipes-google/host-power-ctrl/gpio-host-pwr_git.bb
parent04cd92067d2481643df5010cb39b2134b648cf4d (diff)
parentffe6d597d9e3d4407cf8062b5d6505a80ce08f41 (diff)
downloadopenbmc-0c9e31989c615598b5d042ffab385606660c93c0.tar.xz
Merge pull request #72 from Intel-BMC/update2021-0.751-0.75
Update
Diffstat (limited to 'meta-google/recipes-google/host-power-ctrl/gpio-host-pwr_git.bb')
-rw-r--r--meta-google/recipes-google/host-power-ctrl/gpio-host-pwr_git.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-google/recipes-google/host-power-ctrl/gpio-host-pwr_git.bb b/meta-google/recipes-google/host-power-ctrl/gpio-host-pwr_git.bb
new file mode 100644
index 000000000..e63260c56
--- /dev/null
+++ b/meta-google/recipes-google/host-power-ctrl/gpio-host-pwr_git.bb
@@ -0,0 +1,57 @@
+SUMMARY = "GPIO based powercontrol for a host system"
+DESCRIPTION = "GPIO based powercontrol for a host system."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+RDEPENDS:${PN} += " \
+ bash \
+ gpio-ctrl \
+ "
+
+SRC_URI += " \
+ file://host-ensure-off.service \
+ file://host-powercycle-watchdog.service \
+ file://host-powercycle.service \
+ file://host-poweroff-watchdog.service \
+ file://host-poweroff.service \
+ file://host-poweron.service \
+ file://host-reset-cold-watchdog.service \
+ file://host-reset-cold.service \
+ file://host-reset-warm-watchdog.service \
+ file://host-reset-warm.service \
+ file://host_ensure_off.sh \
+ file://host_isoff.sh \
+ file://host_powercycle.sh \
+ file://host_poweroff.sh \
+ file://host_poweron.sh \
+ file://host_reset.sh \
+ file://lib.sh \
+ "
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} += " \
+ host-reset-cold.service \
+ host-reset-cold-watchdog.service \
+ host-reset-warm.service \
+ host-reset-warm-watchdog.service \
+ host-ensure-off.service \
+ host-powercycle.service \
+ host-powercycle-watchdog.service \
+ host-poweroff.service \
+ host-poweroff-watchdog.service \
+ host-poweron.service \
+ "
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/host_*.sh ${D}${bindir}/
+
+ install -d ${D}${datadir}/gpio-host-pwr
+ install -m 0755 ${WORKDIR}/lib.sh ${D}${datadir}/gpio-host-pwr/
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/*.service ${D}${systemd_system_unitdir}/
+}