summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-08-03 01:45:08 +0300
committerGitHub <noreply@github.com>2021-08-03 01:45:08 +0300
commit10ad77d5bc86709d8ff7f95e7040e39f1c153903 (patch)
tree307cedb87f4c0a329740c55ac364ed489d1d8fc2 /meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
parentc6b1c6ba7a01b7987d65d61c262c44c320193108 (diff)
parent67327ddc580cb9a85219a534844832a1682780d4 (diff)
downloadopenbmc-10ad77d5bc86709d8ff7f95e7040e39f1c153903.tar.xz
Merge pull request #69 from Intel-BMC/update2021-0.631-0.63
Update
Diffstat (limited to 'meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb')
-rw-r--r--meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb38
1 files changed, 17 insertions, 21 deletions
diff --git a/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb b/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
index 70c4bcb39..6acf234cf 100644
--- a/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
+++ b/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
@@ -6,34 +6,30 @@ PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit autotools pkgconfig
-inherit systemd
-inherit obmc-phosphor-ipmiprovider-symlink
+inherit meson pkgconfig systemd
-DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus"
-DEPENDS += "phosphor-logging"
-DEPENDS += "phosphor-ipmi-host"
-DEPENDS += "nlohmann-json"
+DEPENDS += " \
+ nlohmann-json \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ phosphor-ipmi-host \
+ sdbusplus \
+ systemd \
+ "
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
-SRCREV = "3b1b427c1fa4bcddcab1fc003410e5fa5d7a8334"
+SRCREV = "bc62b193aec2991397a7f671cd3a74492a961d5c"
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
-
-HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
+FILES_${PN} += "${libdir}/ipmid-providers"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
+SYSTEMD_SERVICE_${PN} += " \
+ gbmc-host-poweroff.target \
+ gbmc-psu-hardreset.target \
+ "
+
+EXTRA_OEMESON += "-Dtests=disabled"
CXXFLAGS_append_gbmc = '${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else \
" -DNCSI_IPMI_CHANNEL=1 -DNCSI_IF_NAME=" + d.getVar("GBMC_NCSI_IF_NAME")}'
-
-do_install_append() {
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
-}