summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
diff options
context:
space:
mode:
authorAndrew Geissler <openbmcbump-github@yahoo.com>2021-06-24 14:00:17 +0300
committerWilliam A. Kennington III <wak@google.com>2021-06-25 01:10:37 +0300
commitf64c3c0c133c4fa915b93f771d2a1c7213312046 (patch)
treedf971dbf4b91f539f678ac90dec590d28408f0cc /meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
parent85dd691695fa25cbc12a8935bbf7d33d5ebd4701 (diff)
downloadopenbmc-f64c3c0c133c4fa915b93f771d2a1c7213312046.tar.xz
google-ipmi-sys: srcrev bump 3b1b427c1f..ac730af213
William A. Kennington III (3): makefile: Fix target install treewide: Cleanup pedantic C++ warnings build: Add meson build linyuny (1): Add new google ipmi sys command: SysHostPowerOff Change-Id: I988b24ca97d95ffa4ef7332741b682f1fae06011 Signed-off-by: Andrew Geissler <openbmcbump-github@yahoo.com> Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb')
-rw-r--r--meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb38
1 files changed, 16 insertions, 22 deletions
diff --git a/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb b/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
index 0bcc66a58..8ff1d5d51 100644
--- a/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
+++ b/meta-google/recipes-google/ipmi/google-ipmi-sys_git.bb
@@ -6,36 +6,30 @@ PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit autotools pkgconfig
-inherit systemd
-inherit obmc-phosphor-ipmiprovider-symlink
+inherit meson pkgconfig systemd
-DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus"
-DEPENDS += "phosphor-logging"
-DEPENDS += "phosphor-ipmi-host"
-DEPENDS += "nlohmann-json"
+DEPENDS += " \
+ nlohmann-json \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ phosphor-ipmi-host \
+ sdbusplus \
+ systemd \
+ "
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
-SRCREV = "3b1b427c1fa4bcddcab1fc003410e5fa5d7a8334"
+SRCREV = "ac730af213ab4912be5cbe8d260485ca666f2176"
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
-
-HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
+FILES_${PN} += "${libdir}/ipmid-providers"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
+SYSTEMD_SERVICE_${PN} += " \
+ gbmc-host-poweroff.target \
+ gbmc-psu-hardreset.target \
+ "
-EXTRA_OECONF += "--disable-tests"
+EXTRA_OEMESON += "-Dtests=disabled"
CXXFLAGS_append_gbmc = '${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else \
" -DNCSI_IPMI_CHANNEL=1 -DNCSI_IF_NAME=" + d.getVar("GBMC_NCSI_IF_NAME")}'
-
-do_install_append() {
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
-}