summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/networking/gbmc-iperf3.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-04-23 22:53:36 +0300
committerWilliam A. Kennington III <wak@google.com>2021-05-07 04:09:53 +0300
commit832f02b111487b37e71c0170795cb0db6ce1732a (patch)
tree651a4b956784ca96bc04297ceb10818114bca086 /meta-google/recipes-google/networking/gbmc-iperf3.bb
parent29dfcd8a0f2124d1b2e331683012548f7d416515 (diff)
downloadopenbmc-832f02b111487b37e71c0170795cb0db6ce1732a.tar.xz
meta-google: gbmc-bridge: Add package
This adds a machine local ethernet network which allows BMCs to communicate with one another. Change-Id: I5e0ace231af02d84f7678b8241b5ec71823e86af Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/networking/gbmc-iperf3.bb')
-rw-r--r--meta-google/recipes-google/networking/gbmc-iperf3.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-iperf3.bb b/meta-google/recipes-google/networking/gbmc-iperf3.bb
index 5044e418b..27ebdb7e0 100644
--- a/meta-google/recipes-google/networking/gbmc-iperf3.bb
+++ b/meta-google/recipes-google/networking/gbmc-iperf3.bb
@@ -17,13 +17,13 @@ do_install() {
install -m 0644 ${WORKDIR}/iperf3.service ${D}${systemd_system_unitdir}
}
-# Allow IPERF3 to the mgmt node on DEV builds
+# Allow IPERF3 to run on the gbmcbr node on DEV builds
do_install_append_dev() {
nftables_dir=${D}${sysconfdir}/nftables
rules=$nftables_dir/50-gbmc-iperf3-dev.rules
install -d -m0755 $nftables_dir
echo 'table inet filter {' >"$rules"
- echo ' chain mgmt_pub_input {' >>"$rules"
+ echo ' chain gbmc_br_pub_input {' >>"$rules"
echo ' tcp dport 5201 accept' >>"$rules"
echo ' }' >>"$rules"
echo '}' >>"$rules"