summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/networking/network-sh.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-03-09 00:00:12 +0300
committerWilliam A. Kennington III <wak@google.com>2021-04-23 23:05:23 +0300
commit1e268105977df1f238c18f58eb5bca20fec3aecc (patch)
tree3b2590b7aba9af4dc8e8e193e0f7b0140d0ecdeb /meta-google/recipes-google/networking/network-sh.bb
parent6fae14e51c7e1f9d97289727bf51960e01acdb58 (diff)
downloadopenbmc-1e268105977df1f238c18f58eb5bca20fec3aecc.tar.xz
meta-google: network-sh: Add library
Provides a utility for working with network type data. Right now this is just for MAC address parsing and conversion to EUI{48,64}. Change-Id: I49946d8147f1c7b10cfe3a9e55b20fc30c083eda Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/networking/network-sh.bb')
-rw-r--r--meta-google/recipes-google/networking/network-sh.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-google/recipes-google/networking/network-sh.bb b/meta-google/recipes-google/networking/network-sh.bb
new file mode 100644
index 000000000..a377b9e2a
--- /dev/null
+++ b/meta-google/recipes-google/networking/network-sh.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Shell functions for manipulating network addresses"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://lib.sh"
+SRC_URI += "file://test.sh"
+S = "${WORKDIR}"
+
+DATA = "${datadir}/network"
+FILES_${PN} += "${DATA}"
+
+DEPENDS += "test-sh"
+
+do_compile() {
+ SYSROOT="$PKG_CONFIG_SYSROOT_DIR" bash test.sh || exit
+}
+
+do_install_append() {
+ install -d -m0755 ${D}${DATA}
+ install -m0644 lib.sh ${D}${DATA}/
+}