summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/networking
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-03-09 01:31:28 +0300
committerWilliam A. Kennington III <wak@google.com>2021-03-09 07:55:47 +0300
commit726cef823c3db155482bfcbb98fe77afb43992cc (patch)
treedbe52cda7b9c1fa824bfba28d11508f324c7bad6 /meta-google/recipes-google/networking
parentc20feb7b192779112e702b8081d63b3d9a610867 (diff)
downloadopenbmc-726cef823c3db155482bfcbb98fe77afb43992cc.tar.xz
meta-google: gbmc-iperf3: Allow for DEV builds
Change-Id: Ib2cc970201324affc212b644598ef39f4cafffbb Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/networking')
-rw-r--r--meta-google/recipes-google/networking/gbmc-iperf3.bb18
1 files changed, 15 insertions, 3 deletions
diff --git a/meta-google/recipes-google/networking/gbmc-iperf3.bb b/meta-google/recipes-google/networking/gbmc-iperf3.bb
index f1a88b459..5044e418b 100644
--- a/meta-google/recipes-google/networking/gbmc-iperf3.bb
+++ b/meta-google/recipes-google/networking/gbmc-iperf3.bb
@@ -12,7 +12,19 @@ SRC_URI += "file://iperf3.service"
SYSTEMD_SERVICE_${PN} += "iperf3.service"
do_install() {
- # Install service definitions
- install -d -m 0755 ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/iperf3.service ${D}${systemd_system_unitdir}
+ # Install service definitions
+ install -d -m 0755 ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/iperf3.service ${D}${systemd_system_unitdir}
+}
+
+# Allow IPERF3 to the mgmt node on DEV builds
+do_install_append_dev() {
+ nftables_dir=${D}${sysconfdir}/nftables
+ rules=$nftables_dir/50-gbmc-iperf3-dev.rules
+ install -d -m0755 $nftables_dir
+ echo 'table inet filter {' >"$rules"
+ echo ' chain mgmt_pub_input {' >>"$rules"
+ echo ' tcp dport 5201 accept' >>"$rules"
+ echo ' }' >>"$rules"
+ echo '}' >>"$rules"
}