summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/networking
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-02-17 01:57:41 +0300
committerWilliam A. Kennington III <wak@google.com>2021-02-17 22:00:50 +0300
commit7f11d1ffd591a1cf63b7a6de87c7c257a6ed99ea (patch)
tree02d1a0572fa21160108b6c4760a34dd0c8894873 /meta-google/recipes-google/networking
parentd45e4b3403c5a844c93be4faa4cefce631f537d0 (diff)
downloadopenbmc-7f11d1ffd591a1cf63b7a6de87c7c257a6ed99ea.tar.xz
meta-google: Fold gbmc-sslh into gbmc-ncsi-config
Logically these packages belong together and don't make much sense without each other. Combine them to reduce package complexity for users. Change-Id: I3d3998f8d10cacbd01f6d883b0033a3260ff60df Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/networking')
-rw-r--r--meta-google/recipes-google/networking/files/sslh.service20
-rw-r--r--meta-google/recipes-google/networking/files/sslh.socket8
-rw-r--r--meta-google/recipes-google/networking/gbmc-sslh.bb23
3 files changed, 0 insertions, 51 deletions
diff --git a/meta-google/recipes-google/networking/files/sslh.service b/meta-google/recipes-google/networking/files/sslh.service
deleted file mode 100644
index b6bc04a4c..000000000
--- a/meta-google/recipes-google/networking/files/sslh.service
+++ /dev/null
@@ -1,20 +0,0 @@
-[Unit]
-Description=SSL/SSH multiplexer
-Requires=sslh.socket
-
-[Service]
-ExecStart=/usr/sbin/sslh -n -f --ssh [::1]:22 --http [::1]:80 --tls [::1]:443
-KillMode=process
-#Hardening
-PrivateTmp=true
-ProtectSystem=strict
-ProtectHome=true
-ProtectKernelModules=true
-ProtectKernelTunables=true
-ProtectControlGroups=true
-MountFlags=private
-NoNewPrivileges=true
-PrivateDevices=true
-RestrictAddressFamilies=AF_INET AF_INET6 AF_UNIX
-MemoryDenyWriteExecute=true
-DynamicUser=true
diff --git a/meta-google/recipes-google/networking/files/sslh.socket b/meta-google/recipes-google/networking/files/sslh.socket
deleted file mode 100644
index 2540e5961..000000000
--- a/meta-google/recipes-google/networking/files/sslh.socket
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Before=sslh.service
-
-[Socket]
-ListenStream=3967
-
-[Install]
-WantedBy=sockets.target
diff --git a/meta-google/recipes-google/networking/gbmc-sslh.bb b/meta-google/recipes-google/networking/gbmc-sslh.bb
deleted file mode 100644
index ec16f078f..000000000
--- a/meta-google/recipes-google/networking/gbmc-sslh.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-PR = "r1"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit systemd
-
-RDEPENDS_${PN} += "sslh"
-
-SRC_URI_append = " \
- file://sslh.service \
- file://sslh.socket \
-"
-
-SYSTEMD_SERVICE_${PN} += "sslh.service"
-SYSTEMD_SERVICE_${PN} += "sslh.socket"
-
-do_install() {
- # Install service definitions
- install -d -m 0755 ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/sslh.service ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/sslh.socket ${D}${systemd_system_unitdir}
-}