summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/nftables/nftables-systemd.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-03-26 01:28:45 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-03-26 01:28:45 +0300
commit0a1ece0568a37de9f17fd6e0bcdfd2cad2c6503f (patch)
treeb985c9ca29cb3cf19b04e248c868fa18abf07dcc /meta-google/recipes-google/nftables/nftables-systemd.bb
parent0cfc19e6565d8e3a1aa563c59edb347f9128026f (diff)
parent983ec41074988cf15d98bf8c929efee125682eeb (diff)
downloadopenbmc-0a1ece0568a37de9f17fd6e0bcdfd2cad2c6503f.tar.xz
Merge tag '0.43' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-google/recipes-google/nftables/nftables-systemd.bb')
-rw-r--r--meta-google/recipes-google/nftables/nftables-systemd.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-google/recipes-google/nftables/nftables-systemd.bb b/meta-google/recipes-google/nftables/nftables-systemd.bb
new file mode 100644
index 000000000..24d3e821b
--- /dev/null
+++ b/meta-google/recipes-google/nftables/nftables-systemd.bb
@@ -0,0 +1,17 @@
+SUMMARY = "nftables systemd wrapper"
+DESCRIPTION = "nftables systemd wrapper"
+PR = "r1"
+PV = "1.0"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+SRC_URI += "file://nftables.service"
+SYSTEMD_SERVICE_${PN} += "nftables.service"
+
+do_install() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}
+}