summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/nftables
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-03-08 22:59:56 +0300
committerWilliam A. Kennington III <wak@google.com>2021-03-09 00:34:19 +0300
commit9b16719a1fc70f1a478f1f99dc14b8a02ea4c5ba (patch)
tree2b0bfd74ac4cd5b2aa13d49ce63444c3e33f84f7 /meta-google/recipes-google/nftables
parentee38b8c72a3f18fdb125a16bfb4a51e5ca41af44 (diff)
downloadopenbmc-9b16719a1fc70f1a478f1f99dc14b8a02ea4c5ba.tar.xz
meta-google: nftables-systemd: Add missing RDEPENDS
Change-Id: I4700ccc2d96385f9c7113e402ca9e1c9f788f399 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google/nftables')
-rw-r--r--meta-google/recipes-google/nftables/nftables-systemd.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-google/recipes-google/nftables/nftables-systemd.bb b/meta-google/recipes-google/nftables/nftables-systemd.bb
index 24d3e821b..03694c8c5 100644
--- a/meta-google/recipes-google/nftables/nftables-systemd.bb
+++ b/meta-google/recipes-google/nftables/nftables-systemd.bb
@@ -11,6 +11,11 @@ inherit systemd
SRC_URI += "file://nftables.service"
SYSTEMD_SERVICE_${PN} += "nftables.service"
+RDEPENDS_${PN} += " \
+ bash \
+ nftables \
+ "
+
do_install() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}