summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google/test/test-sh.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-05-24 22:35:24 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-05-24 22:35:24 +0300
commit0e0df451ae365f09d5c0c766b253f23de26901f2 (patch)
treedb4d7d3ce85e02ee01ad58a86ede02ac876aae77 /meta-google/recipes-google/test/test-sh.bb
parente370fd750e2821620ec427f26f8efab0069824ff (diff)
parent7e10dee74964afa47859704886128dd256acf854 (diff)
downloadopenbmc-0e0df451ae365f09d5c0c766b253f23de26901f2.tar.xz
Merge tag '0.52' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-google/recipes-google/test/test-sh.bb')
-rw-r--r--meta-google/recipes-google/test/test-sh.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-google/recipes-google/test/test-sh.bb b/meta-google/recipes-google/test/test-sh.bb
new file mode 100644
index 000000000..7edbb9189
--- /dev/null
+++ b/meta-google/recipes-google/test/test-sh.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Shell functions for testing shell scripts"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+SRC_URI += "file://lib.sh"
+SRC_URI += "file://test.sh"
+S = "${WORKDIR}"
+
+DATA = "${datadir}/test"
+FILES_${PN} += "${DATA}"
+
+do_compile() {
+ SYSROOT="$PKG_CONFIG_SYSROOT_DIR" bash test.sh || exit
+}
+
+do_install_append() {
+ install -d -m0755 ${D}${DATA}
+ install -m0644 lib.sh ${D}${DATA}/
+}