summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-09-29 23:15:35 +0300
committerWilliam A. Kennington III <wak@google.com>2021-09-29 23:16:07 +0300
commite0599f220c5c9aacab2f37667d455082f72666fc (patch)
treec96874d0ae778c09d3cab64001ff414c4e6bd4fe /meta-google/recipes-google
parent1bc24a2eec152f6d5b5ba5246adf134d4145423e (diff)
downloadopenbmc-e0599f220c5c9aacab2f37667d455082f72666fc.tar.xz
meta-google: glome: Bump b7084b5c..02f7d272
Copybara-Service (1): Merge pull request #96 from l9i:go-presubmit Piotr Lewandowski (3): Print the ouptut of `gofmt -d` (if any) Print the output of `gofmt -d` (if any) Merge branch 'go-presubmit' of github.com:l9i/glome into go-presubmit William A. Kennington III (1): login/login: Remove glib url escap Change-Id: Ief099a8ebec5d78ce256e32dacb5cf90173bcfc9 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google')
-rw-r--r--meta-google/recipes-google/console/glome_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-google/recipes-google/console/glome_git.bb b/meta-google/recipes-google/console/glome_git.bb
new file mode 100644
index 000000000..b302e72ef
--- /dev/null
+++ b/meta-google/recipes-google/console/glome_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "GLOME Login Client"
+DESCRIPTION = "GLOME login is first application of the GLOME protocol. It is used to authorize serial console access to Linux machines"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit meson pkgconfig
+
+DEPENDS += " \
+ openssl \
+ glib-2.0 \
+ "
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/google/glome.git"
+SRCREV = "02f7d2722a2eb303f1f02d0c2ce97a65f8273662"
+
+FILES_${PN} += "${libdir}/security"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[glome-cli] = "-Dglome-cli=true,-Dglome-cli=false"
+PACKAGECONFIG[pam-glome] = "-Dpam-glome=true,-Dpam-glome=false,libpam"
+
+EXTRA_OEMESON = "-Dtests=disabled"