summaryrefslogtreecommitdiff
path: root/meta-google/recipes-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-03-24 21:12:07 +0300
committerWilliam A. Kennington III <wak@google.com>2021-03-25 00:39:57 +0300
commit511bd615b05d08e441c036271b532bc9b699258f (patch)
treeec432425e5d008d5b40dcb9fd4773c5ab86ee246 /meta-google/recipes-google
parentcbb15ab4921045abe0c36de112e719108eb9b294 (diff)
downloadopenbmc-511bd615b05d08e441c036271b532bc9b699258f.tar.xz
meta-google: google-misc: Split into include
We don't want to generate bump commits for each project in the repo. Instead, provide an include that has common parameters used by all google-misc projects. Change-Id: Ice589c03aa0d38ca5043ee2081f3757568c4e4bb Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-google')
-rw-r--r--meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb31
-rw-r--r--meta-google/recipes-google/google-misc/google-misc.inc12
-rw-r--r--meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb35
-rw-r--r--meta-google/recipes-google/ncsi/ncsid_git.bb19
4 files changed, 46 insertions, 51 deletions
diff --git a/meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb b/meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb
index 4e27309de..0755d4eab 100644
--- a/meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb
+++ b/meta-google/recipes-google/acpi-power-state-daemon/acpi-power-state-daemon_git.bb
@@ -1,28 +1,19 @@
SUMMARY = "ACPI Power/Sleep state daemon to allow host state events"
DESCRIPTION = "ACPI Power/Sleep state daemon to allow host state events"
-HOMEPAGE = "http://github.com/openbmc/google-misc"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
+GOOGLE_MISC_PROJ = "acpi-power-state-daemon"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://../LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+require ../google-misc/google-misc.inc
-SRC_URI += "git://github.com/openbmc/google-misc"
-SRCREV = "1285115c16180bd28a3cfe79d9db8d10c84fe2ed"
-S = "${WORKDIR}/git/acpi-power-state-daemon"
-
-inherit meson
-inherit pkgconfig
-inherit systemd
+inherit pkgconfig systemd
DEPENDS += " \
- phosphor-dbus-interfaces \
- sdbusplus \
- systemd \
- "
+ phosphor-dbus-interfaces \
+ sdbusplus \
+ systemd \
+ "
SYSTEMD_SERVICE_${PN} = " \
- acpi-power-state.service \
- host-s0-state.target \
- host-s5-state.target \
- "
+ acpi-power-state.service \
+ host-s0-state.target \
+ host-s5-state.target \
+ "
diff --git a/meta-google/recipes-google/google-misc/google-misc.inc b/meta-google/recipes-google/google-misc/google-misc.inc
new file mode 100644
index 000000000..6146b2e62
--- /dev/null
+++ b/meta-google/recipes-google/google-misc/google-misc.inc
@@ -0,0 +1,12 @@
+HOMEPAGE = "http://github.com/openbmc/google-misc"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../../LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI += "git://github.com/openbmc/google-misc"
+SRCREV = "b056df698ca4405b7adfa5bbf931f4b8a9431e55"
+
+S = "${WORKDIR}/git/subprojects/${GOOGLE_MISC_PROJ}"
+inherit meson
diff --git a/meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb b/meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb
index 3eefb9d8c..4518f49b5 100644
--- a/meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb
+++ b/meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb
@@ -1,28 +1,27 @@
-HOMEPAGE = "http://github.com/openbmc/google-misc"
SUMMARY = "gBMC Health Metrics Blob"
DESCRIPTION = "BMC health metrics IPMI blob handler."
-PR = "r1"
-PV = "0.1+git${SRCPV}"
-LICENSE = "Apache-2.0"
+GOOGLE_MISC_PROJ = "metrics-ipmi-blobs"
-inherit meson pkgconfig
+require ../google-misc/google-misc.inc
-DEPENDS += "phosphor-ipmi-blobs"
-DEPENDS += "phosphor-logging"
-DEPENDS += "protobuf-native"
-DEPENDS += "protobuf"
+inherit pkgconfig
-SRC_URI = "git://github.com/openbmc/google-misc"
-SRCREV = "b056df698ca4405b7adfa5bbf931f4b8a9431e55"
-S = "${WORKDIR}/git/metrics-ipmi-blobs"
-
-FILES_${PN} += "${libdir}/ipmid-providers/libmetricsblob.so*"
-FILES_${PN} += "${libdir}/blob-ipmid/libmetricsblob.so*"
-INSANE_SKIP_${PN} += "dev-so"
+DEPENDS += " \
+ phosphor-ipmi-blobs \
+ phosphor-logging \
+ protobuf-native \
+ protobuf \
+ "
+FILES_${PN} += " \
+ ${libdir}/ipmid-providers/libmetricsblob.so* \
+ ${libdir}/blob-ipmid/libmetricsblob.so* \
+ "
BLOBIPMI_PROVIDER_LIBRARY += "libmetricsblob.so"
+INSANE_SKIP_${PN} += "dev-so"
+
do_install_append() {
- install -d ${D}/${libdir}/blob-ipmid
- ln -s ../ipmid-providers/libmetricsblob.so ${D}/${libdir}/blob-ipmid/libmetricsblob.so.0
+ install -d ${D}/${libdir}/blob-ipmid
+ ln -s ../ipmid-providers/libmetricsblob.so ${D}/${libdir}/blob-ipmid/libmetricsblob.so.0
}
diff --git a/meta-google/recipes-google/ncsi/ncsid_git.bb b/meta-google/recipes-google/ncsi/ncsid_git.bb
index 4972ce854..4d74c992a 100644
--- a/meta-google/recipes-google/ncsi/ncsid_git.bb
+++ b/meta-google/recipes-google/ncsi/ncsid_git.bb
@@ -1,17 +1,10 @@
SUMMARY = "Google NCSI daemon"
DESCRIPTION = "Google NCSI daemon."
-HOMEPAGE = "http://github.com/openbmc/google-misc"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
+GOOGLE_MISC_PROJ = "ncsid"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://../LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+require ../google-misc/google-misc.inc
-SRC_URI += "git://github.com/openbmc/google-misc"
-SRCREV = "1285115c16180bd28a3cfe79d9db8d10c84fe2ed"
-S = "${WORKDIR}/git/ncsid"
-
-inherit meson systemd
+inherit systemd
SYSTEMD_SERVICE_${PN} += " \
dhcp4@.service \
@@ -21,13 +14,13 @@ SYSTEMD_SERVICE_${PN} += " \
nic-hostless@.target \
update-static-neighbors@.service \
update-static-neighbors@.timer \
-"
+ "
DEPENDS += " \
fmt \
sdbusplus \
stdplus \
-"
+ "
RDEPENDS_${PN} += " \
bash \
@@ -37,4 +30,4 @@ RDEPENDS_${PN} += " \
ndisc6-ndisc6 \
ndisc6-rdisc6 \
systemd \
-"
+ "