summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb
diff options
context:
space:
mode:
authorBrandon Kim <brandonkim@google.com>2021-07-21 01:48:31 +0300
committerBrandon Kim <brandonkim@google.com>2021-08-02 19:23:11 +0300
commit236c94eb62df7d2694225996d83c51d45594004f (patch)
treec3538c5823cd70ca99374c6af899464f5d7271f7 /meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb
parent8bb79f27b6e61b856bd75fc0316e66326eadef8f (diff)
downloadopenbmc-236c94eb62df7d2694225996d83c51d45594004f.tar.xz
meta-google: flash: Import dummy-gbmc-update
Dummy image uploader for sending debug binaries. Google-Bug-Id: 179618162 Upstream: 22e2c3dd5f610777dee173a09d8e82dc2509a975 Signed-off-by: Brandon Kim <brandonkim@google.com> Change-Id: I53c0defeefffa007d71d68ceeb2602d83c22f523
Diffstat (limited to 'meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb')
-rw-r--r--meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb b/meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb
new file mode 100644
index 000000000..7eba3b0fc
--- /dev/null
+++ b/meta-google/recipes-phosphor/flash/dummy-gbmc-update.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Dummy image uploader for sending debug binaries"
+DESCRIPTION = "Dummy image uploader for sending debug binaries"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+SRC_URI += "file://config-dummy.json"
+SRC_URI += "file://dummy-verify.service"
+
+FILES_${PN} += "${datadir}/phosphor-ipmi-flash"
+
+SYSTEMD_SERVICE_${PN} += "dummy-verify.service"
+
+do_install() {
+ install -d ${D}${datadir}/phosphor-ipmi-flash
+ install -m 0644 ${WORKDIR}/config-dummy.json ${D}${datadir}/phosphor-ipmi-flash
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/dummy-verify.service ${D}${systemd_system_unitdir}
+}