summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash/gbmc-update.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-12-04 05:19:07 +0300
committerWilliam A. Kennington III <wak@google.com>2021-12-07 07:14:22 +0300
commit32e440d8706ca2106d7d2a7a6013732cba529f21 (patch)
tree47090c27a0f5b4d18adcca18a74d0631d935d19b /meta-google/recipes-phosphor/flash/gbmc-update.bb
parentd1a214d0e2516524475ee45ae860d7aa0f2b3e10 (diff)
downloadopenbmc-32e440d8706ca2106d7d2a7a6013732cba529f21.tar.xz
meta-google: inplace-gbmc-update: Add dhcp hook
This makes it possible for the BMC to fetch an upgraded image during DHCP time and perform an inplace update to the new version. Change-Id: I6d32af306180dd52d4235ba4edbb80c3e49756d7 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-phosphor/flash/gbmc-update.bb')
-rw-r--r--meta-google/recipes-phosphor/flash/gbmc-update.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-google/recipes-phosphor/flash/gbmc-update.bb b/meta-google/recipes-phosphor/flash/gbmc-update.bb
new file mode 100644
index 000000000..2c0f51066
--- /dev/null
+++ b/meta-google/recipes-phosphor/flash/gbmc-update.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Google BMC Update Utilities"
+DESCRIPTION = "Google BMC Update Utilities"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI += " \
+ file://75-gbmc-upgrade.sh \
+"
+
+FILES:${PN} += "${datadir}/gbmc-br-dhcp"
+
+do_install() {
+ install -d ${D}${datadir}/gbmc-br-dhcp
+ install -m 0644 ${WORKDIR}/75-gbmc-upgrade.sh ${D}${datadir}/gbmc-br-dhcp/
+}