summaryrefslogtreecommitdiff
path: root/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-12-04 05:19:07 +0300
committerWilliam A. Kennington III <wak@google.com>2021-12-07 07:14:22 +0300
commit32e440d8706ca2106d7d2a7a6013732cba529f21 (patch)
tree47090c27a0f5b4d18adcca18a74d0631d935d19b /meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
parentd1a214d0e2516524475ee45ae860d7aa0f2b3e10 (diff)
downloadopenbmc-32e440d8706ca2106d7d2a7a6013732cba529f21.tar.xz
meta-google: inplace-gbmc-update: Add dhcp hook
This makes it possible for the BMC to fetch an upgraded image during DHCP time and perform an inplace update to the new version. Change-Id: I6d32af306180dd52d4235ba4edbb80c3e49756d7 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb')
-rw-r--r--meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb b/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
index 9e55afce5..418ee3932 100644
--- a/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
+++ b/meta-google/recipes-phosphor/flash/inplace-gbmc-update.bb
@@ -10,8 +10,11 @@ inherit obmc-phosphor-systemd
PROVIDES += "virtual/bmc-update"
RPROVIDES:${PN} += "virtual/bmc-update"
-RDEPENDS:${PN} += "google-key"
-RDEPENDS:${PN} += "bash"
+RDEPENDS:${PN} += " \
+ bash \
+ gbmc-update \
+ google-key \
+ "
SRC_URI += " \
file://config-bmc.json \
@@ -19,12 +22,14 @@ SRC_URI += " \
file://inplace-gbmc-verify.sh \
file://inplace-gbmc-version.service \
file://inplace-gbmc-version.sh \
+ file://75-inplace-gbmc-upgrade.sh \
"
SYSTEMD_SERVICE:${PN} += "inplace-gbmc-verify.service"
SYSTEMD_SERVICE:${PN} += "inplace-gbmc-version.service"
FILES:${PN} += "${datadir}/phosphor-ipmi-flash"
+FILES:${PN} += "${datadir}/gbmc-br-dhcp"
do_install() {
sed -i 's,@ALLOW_DEV@,,' ${WORKDIR}/inplace-gbmc-verify.sh
@@ -37,6 +42,9 @@ do_install() {
install -d ${D}${datadir}/phosphor-ipmi-flash
install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
+
+ install -d ${D}${datadir}/gbmc-br-dhcp
+ install -m 0644 ${WORKDIR}/75-inplace-gbmc-upgrade.sh ${D}${datadir}/gbmc-br-dhcp/
}
do_install:prepend:dev() {