summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorSui Chen <suichen@google.com>2021-03-18 03:10:55 +0300
committerSui Chen <suichen@google.com>2021-03-19 20:54:47 +0300
commitbc63f797465f381054fce0fc00dd788a55f71bc9 (patch)
treee338c10f386fe48d6aee6199c2273ebd728474fb /meta-google
parente942e12bb39706c62397b92a16b713cbe13e7189 (diff)
downloadopenbmc-bc63f797465f381054fce0fc00dd788a55f71bc9.tar.xz
recipes-google: Add metrics-ipmi-blobs
metrics-ipmi-blobs provides a set of BMC health info through an IPMI blob. Tested: After adding the meta-google layer, the recipe "metrics-ipmi-blobs" shows up in `bitbake-layers show-recipes`. Change-Id: I0239644c16cecdf9a959b646bbab570737d4ee15 Signed-off-by: Sui Chen <suichen@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb b/meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb
new file mode 100644
index 000000000..86ab7cc73
--- /dev/null
+++ b/meta-google/recipes-google/ipmi/metrics-ipmi-blobs_git.bb
@@ -0,0 +1,28 @@
+HOMEPAGE = "http://github.com/openbmc/google-misc"
+SUMMARY = "gBMC Health Metrics Blob"
+DESCRIPTION = "BMC health metrics IPMI blob handler."
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+
+inherit meson pkgconfig
+
+DEPENDS += "phosphor-ipmi-blobs"
+DEPENDS += "phosphor-logging"
+DEPENDS += "protobuf-native"
+DEPENDS += "protobuf"
+
+SRC_URI = "git://github.com/openbmc/google-misc"
+SRCREV = "3f43b7eebe17c96c13643018c927f38c0a071868"
+S = "${WORKDIR}/git/metrics-ipmi-blobs"
+
+FILES_${PN} += "${libdir}/ipmid-providers/libmetricsblob.so*"
+FILES_${PN} += "${libdir}/blob-ipmid/libmetricsblob.so*"
+INSANE_SKIP_${PN} += "dev-so"
+
+BLOBIPMI_PROVIDER_LIBRARY += "libmetricsblob.so"
+
+do_install_append() {
+ install -d ${D}/${libdir}/blob-ipmid
+ ln -s ../ipmid-providers/libmetricsblob.so ${D}/${libdir}/blob-ipmid/libmetricsblob.so.0
+}