summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-24 21:10:32 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-24 23:47:00 +0300
commit19d2050424e385f9fff936645af0e6b5b6de4d05 (patch)
tree38dcb684de7e89cafc241f75e20e1559640c4c4b /meta-google
parent4fa0bb23cfb7490a04865255013b16b37aa2575c (diff)
downloadopenbmc-19d2050424e385f9fff936645af0e6b5b6de4d05.tar.xz
meta-google: add google-ipmi-i2c package
Add the google-ipmi-i2c package. This package handles a OEM IPMI commands that provide read and write to i2c devices attached to the BMC. Tested: Built by adding to image and verified library installed. (From meta-google rev: 7e55649a5e6a0683a1b2612cad1c2327e913513c) Change-Id: I07972430df153fb758ac7928a1cf5aa1120a4dde Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/ipmi/google-ipmi-i2c_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-google/recipes-google/ipmi/google-ipmi-i2c_git.bb b/meta-google/recipes-google/ipmi/google-ipmi-i2c_git.bb
new file mode 100644
index 000000000..3801e9907
--- /dev/null
+++ b/meta-google/recipes-google/ipmi/google-ipmi-i2c_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Google i2c OEM commands"
+DESCRIPTION = "Google i2c OEM commands"
+HOMEPAGE = "https://github.com/openbmc/google-ipmi-i2c"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "phosphor-ipmi-host"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/google-ipmi-i2c"
+SRCREV = "38e8c6e1706522dec1973e148e24020361fb2042"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libi2ccmds.so"