summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorTom Tung <tomtung@google.com>2021-08-06 10:20:42 +0300
committerTom Tung <shes050117@gmail.com>2021-08-10 08:18:12 +0300
commit959379abc1f2279ebc0a102b4091b0d775781747 (patch)
tree15d73e77ab449ae20c882d4fca13b315d0b297dd /meta-google
parent48ea66bf4889bc86f19c9da78c342d2f18dbbabc (diff)
downloadopenbmc-959379abc1f2279ebc0a102b4091b0d775781747.tar.xz
meta-google: host-power-ctrl: Import libwatchdog from gBMC
Upstream package for libwatchdog. Change-Id: I9ef9243ae8e56a4a92be31c9229f1b38c00f662d Signed-off-by: Tom Tung <shes050117@gmail.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/host-power-ctrl/libwatchdog/libwatchdog.sh33
-rw-r--r--meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb16
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-google/recipes-google/host-power-ctrl/libwatchdog/libwatchdog.sh b/meta-google/recipes-google/host-power-ctrl/libwatchdog/libwatchdog.sh
new file mode 100644
index 000000000..dcb39692a
--- /dev/null
+++ b/meta-google/recipes-google/host-power-ctrl/libwatchdog/libwatchdog.sh
@@ -0,0 +1,33 @@
+#!/bin/bash
+# Copyright 2021 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+##################################################
+# Stop the host watchdog
+# Return:
+# 0 if success, non-zero if error
+##################################################
+stop_host_watchdog() {
+ if (( $# != 0 )); then
+ echo 'Usage: stop_host_watchdog' >&2
+ return 1
+ fi
+
+ local srv='xyz.openbmc_project.Watchdog'
+ local obj='/xyz/openbmc_project/watchdog/host0'
+ local intf='xyz.openbmc_project.State.Watchdog'
+ local method='Enabled'
+ local args=('b' 'false')
+ busctl set-property "${srv}" "${obj}" "${intf}" "${method}" "${args[@]}"
+}
diff --git a/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb b/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
new file mode 100644
index 000000000..771f4b02a
--- /dev/null
+++ b/meta-google/recipes-google/host-power-ctrl/libwatchdog_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Watchdog Shell Library"
+DESCRIPTION = "Watchdog Shell Library"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI += " \
+ file://libwatchdog.sh \
+"
+
+RDEPENDS_${PN} = "bash"
+
+do_install() {
+ install -d ${D}${libexecdir}
+ install -m 0755 ${WORKDIR}/libwatchdog.sh ${D}${libexecdir}/
+}