summaryrefslogtreecommitdiff
path: root/meta-google
diff options
context:
space:
mode:
authorWilliam A. Kennington III <wak@google.com>2021-07-07 23:30:07 +0300
committerWilliam A. Kennington III <wak@google.com>2021-07-07 23:30:44 +0300
commitdce052d39d694a8ed54f37689dcb2a1645727556 (patch)
tree2a8fe163227146666de1730a0a3aeee580ed792f /meta-google
parent1d09d3f983035f92e6d8d88283f7eb64f1cd715a (diff)
downloadopenbmc-dce052d39d694a8ed54f37689dcb2a1645727556.tar.xz
Revert "meta-google: gbmc-kcs-config: Add package"
This reverts commit f93003dd8cf24bd689a7cf24407273b54b9994d4. Change-Id: Ia5ccc39e09d56b0ea083666eb8df3d858f1ac2f5 Signed-off-by: William A. Kennington III <wak@google.com>
Diffstat (limited to 'meta-google')
-rw-r--r--meta-google/recipes-google/kcs/gbmc-kcs-config.bb46
-rw-r--r--meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend2
2 files changed, 0 insertions, 48 deletions
diff --git a/meta-google/recipes-google/kcs/gbmc-kcs-config.bb b/meta-google/recipes-google/kcs/gbmc-kcs-config.bb
deleted file mode 100644
index ca7110660..000000000
--- a/meta-google/recipes-google/kcs/gbmc-kcs-config.bb
+++ /dev/null
@@ -1,46 +0,0 @@
-SUMMARY = "Configures KCS for a gBMC system"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit systemd
-
-S = "${WORKDIR}"
-
-PROVIDES += "virtual-obmc-host-ipmi-hw"
-RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw"
-
-FILES_${PN} += "${systemd_system_unitdir}"
-RDEPENDS_${PN} += "google-kcsbridge"
-
-GBMC_KCS_DEV ?= ""
-
-def systemd_escape_char(c):
- return '\\x{:x}'.format(ord(c))
-
-def systemd_escape(unit):
- import string
- ret = ''
- if len(unit) > 0 and unit[0] == '.':
- ret += systemd_escape_char(unit[0])
- unit = unit[1:]
- for c in unit:
- if c == '/':
- ret += '-'
- elif c not in {*string.ascii_letters, *string.digits, ':', '_', '.'}:
- ret += systemd_escape_char(c)
- else:
- ret += c
- return ret
-
-do_install_append() {
- if [ -z '${GBMC_KCS_DEV}' ]; then
- echo "Missing GBMC_KCS_DEV" >&2
- exit 1
- fi
-
- wantdir=${D}${systemd_system_unitdir}/multi-user.target.wants
- install -d -m0755 $wantdir
- inst="${@systemd_escape(GBMC_KCS_DEV)}"
- ln -sv ../kcsbridge@.service $wantdir/kcsbridge@$inst.service
-}
diff --git a/meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 0c74fc8bb..d8054c363 100644
--- a/meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-google/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -13,5 +13,3 @@ OBMC_IMAGE_EXTRA_INSTALL_append_gbmc = \
'${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else " gbmc-ncsi-config"}'
OBMC_IMAGE_EXTRA_INSTALL_append_gbmc = \
'${@"" if not d.getVar("GBMC_MAC_EEPROM_OF_NAME") else " gbmc-mac-config"}'
-OBMC_IMAGE_EXTRA_INSTALL_append_gbmc = \
- '${@"" if not d.getVar("GBMC_KCS_DEV") else " gbmc-kcs-config"}'