summaryrefslogtreecommitdiff
path: root/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb
diff options
context:
space:
mode:
authorMike Garrett <mike.garrett@hpe.com>2021-08-28 00:39:03 +0300
committerMike Garrett <mike.garrett@hpe.com>2021-09-07 21:31:19 +0300
commit02b54b36f0be0f8dc3aa06b3a83e88feb63c1768 (patch)
tree6cdaa4a96b73c9c62f5d884a41d16e3deaa20b5a /meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb
parente748abe8050a9a2db2309063182244922d75cac7 (diff)
downloadopenbmc-02b54b36f0be0f8dc3aa06b3a83e88feb63c1768.tar.xz
meta-hpe: Update U-Boot from 2019.07 to 2020.10
Signed-off-by: Mike Garrett <mike.garrett@hpe.com> Change-Id: I538f9e74fdc90d3eb1e7e778b2ff99777b0d07d7
Diffstat (limited to 'meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb')
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb
new file mode 100644
index 000000000..daf5a2cde
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb
@@ -0,0 +1,46 @@
+require u-boot-common-gxp_2020.10.inc
+
+SRC_URI += "file://fw_env.config"
+SRC_URI += "file://alt_fw_env.config"
+
+# FIXME - Get fw_printenv/fw_setenv tool
+UBOOT_MACHINE ?= "gxp_defconfig"
+
+SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
+DEPENDS += "mtd-utils"
+
+PROVIDES += "u-boot-fw-utils"
+
+INSANE_SKIP:${PN} = "already-stripped"
+EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE:class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake envtools
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ ln -sf fw_printenv ${D}${base_sbindir}/fw_setenv
+
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 644 ${WORKDIR}/alt_fw_env.config ${D}${sysconfdir}/alt_fw_env.config
+}
+
+do_install:class-cross () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ ln -sf fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+BBCLASSEXTEND = "cross"
+
+RDEPENDS:${PN} = "udev-gxp-mtd-partitions"