summaryrefslogtreecommitdiff
path: root/meta-hpe/meta-gxp
diff options
context:
space:
mode:
authorMike Garrett <mike.garrett@hpe.com>2021-08-25 01:56:32 +0300
committerMike Garrett <mike.garrett@hpe.com>2021-08-25 16:24:40 +0300
commitab6de74f7df8de02fbc3cd92cbfa241d9b70dd1c (patch)
treee7e696e21e1b1f3baecfbbeed0c6b539c4c8a7e9 /meta-hpe/meta-gxp
parentada9e0f89e9ae7d9d70716ffa1306243a2afa5ca (diff)
downloadopenbmc-ab6de74f7df8de02fbc3cd92cbfa241d9b70dd1c.tar.xz
meta-hpe: Changes to support Yocto syntax
Changes to support Yocto syntax changes and latest 'honister' release Signed-off-by: Mike Garrett <mike.garrett@hpe.com> Change-Id: I9cc4eb78b90d9b73bcd0440e6f6f6334fe459481
Diffstat (limited to 'meta-hpe/meta-gxp')
-rw-r--r--meta-hpe/meta-gxp/conf/layer.conf2
-rw-r--r--meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb2
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-hpe/meta-gxp/conf/layer.conf b/meta-hpe/meta-gxp/conf/layer.conf
index 4612c22b0..7a9a11085 100644
--- a/meta-hpe/meta-gxp/conf/layer.conf
+++ b/meta-hpe/meta-gxp/conf/layer.conf
@@ -7,6 +7,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "gxp-layer"
BBFILE_PATTERN_gxp-layer = "^${LAYERDIR}/"
LAYERVERSION_gxp-layer = "1"
-LAYERSERIES_COMPAT_gxp-layer = "hardknott"
+LAYERSERIES_COMPAT_gxp-layer = "hardknott honister"
GXPBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb b/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
index 9954b6397..4321a39de 100644
--- a/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
+++ b/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
S = "${WORKDIR}"
SRC_URI += "file://76-gxp-mtd-partitions.rules"
-RDEPENDS_${PN} += "udev"
+RDEPENDS:${PN} += "udev"
do_install() {
install -d ${D}/${nonarch_base_libdir}/udev/rules.d
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
index 40de352f3..5c172b1c4 100644
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
@@ -10,7 +10,7 @@ KSRC ?= "git://github.com/HewlettPackard/gxp-linux.git;branch=${KBRANCH}"
SRC_URI = "${KSRC}"
SRC_URI += " file://defconfig"
-FILESEXTRAPATHS_prepend_linux-obmc := "${THISDIR}/linux-obmc:"
+FILESEXTRAPATHS:prepend_linux-obmc := "${THISDIR}/linux-obmc:"
LINUX_VERSION_EXTENSION ?= "-${SRCREV}"