summaryrefslogtreecommitdiff
path: root/meta-hpe/meta-gxp
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-hpe/meta-gxp
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-hpe/meta-gxp')
-rw-r--r--meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass5
-rw-r--r--meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass26
-rw-r--r--meta-hpe/meta-gxp/conf/layer.conf2
-rw-r--r--meta-hpe/meta-gxp/conf/machine/include/fitimage-sign.inc14
-rw-r--r--meta-hpe/meta-gxp/conf/machine/include/gxp.inc6
-rw-r--r--meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc2
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/image/files/header-512.sigbin0 -> 20 bytes
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/image/files/header.sigbin0 -> 20 bytes
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb2
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2020.10.inc (renamed from meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2019.07.inc)8
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp/alt_fw_env.config25
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp/fw_env.config25
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb46
-rw-r--r--meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-gxp_2020.10.bb (renamed from meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-gxp_2019.07.bb)3
-rwxr-xr-xmeta-hpe/meta-gxp/recipes-connectivity/jsnbd/jsnbd/state_hook69
-rw-r--r--meta-hpe/meta-gxp/recipes-connectivity/jsnbd/jsnbd_git.bbappend9
-rw-r--r--meta-hpe/meta-gxp/recipes-core/busybox/busybox/FEATURE_FANCY_HEAD.cfg1
-rw-r--r--meta-hpe/meta-gxp/recipes-core/busybox/busybox_%.bbappend2
-rw-r--r--meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb6
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc3
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig35
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb10
-rw-r--r--meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.7.bb9
23 files changed, 271 insertions, 37 deletions
diff --git a/meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass b/meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass
index 206203055..fb3570104 100644
--- a/meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass
+++ b/meta-hpe/meta-gxp/classes/gxp-bootblock-n-poc.bbclass
@@ -4,15 +4,14 @@ LIC_FILES_CHKSUM = ""
BBRANCH = "master"
SRC_URI = "git://github.com/HewlettPackard/gxp-bootblock.git;branch=${BBRANCH}"
-SRCREV = "1d4b424934ab3a2f22cf1b9a459a38e45971509f"
+SRCREV = "bab416f8ca8c8465d308cfeb7f8d5abc21ba343b"
S = "${WORKDIR}/git"
inherit deploy
do_deploy () {
install -d ${DEPLOYDIR}
-
- install -m 644 gxp-bootblock-dl360poc.bin ${DEPLOYDIR}/gxp-bootblock.bin
+ install -m 644 gxp-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin
}
diff --git a/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass b/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass
new file mode 100644
index 000000000..bd69e16a0
--- /dev/null
+++ b/meta-hpe/meta-gxp/classes/gxp-bootblock-n.bbclass
@@ -0,0 +1,26 @@
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+# TODO: Manually copy the U-Boot signing key and customer-key-block here:
+HPE_GXP_KEY_FILES_DIR = "${COREBASE}/meta-hpe/meta-gxp/recipes-bsp/image/files"
+
+inherit deploy
+
+do_deploy () {
+ install -d ${DEPLOYDIR}
+
+ # Copy in the bootblock
+ install -m 644 ${HPE_GXP_KEY_FILES_DIR}/gxp-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin
+
+ # Copy in files from the files subdirectory
+ install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header.sig ${DEPLOYDIR}/hpe-uboot-header.section
+
+ # Copy in the U-Boot signing key
+ install -m 644 ${HPE_GXP_KEY_FILES_DIR}/private_key.pem ${DEPLOYDIR}/hpe-uboot-signing-key.pem
+
+ # Copy in the customer keyblock
+ install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer-key-block ${DEPLOYDIR}/customer-key-block
+}
+
+addtask deploy before do_build after do_compile
+
diff --git a/meta-hpe/meta-gxp/conf/layer.conf b/meta-hpe/meta-gxp/conf/layer.conf
index 28f2ddc87..7a9a11085 100644
--- a/meta-hpe/meta-gxp/conf/layer.conf
+++ b/meta-hpe/meta-gxp/conf/layer.conf
@@ -7,6 +7,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "gxp-layer"
BBFILE_PATTERN_gxp-layer = "^${LAYERDIR}/"
LAYERVERSION_gxp-layer = "1"
-LAYERSERIES_COMPAT_gxp-layer = "gatesgarth hardknott"
+LAYERSERIES_COMPAT_gxp-layer = "hardknott honister"
GXPBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-hpe/meta-gxp/conf/machine/include/fitimage-sign.inc b/meta-hpe/meta-gxp/conf/machine/include/fitimage-sign.inc
new file mode 100644
index 000000000..80af00af2
--- /dev/null
+++ b/meta-hpe/meta-gxp/conf/machine/include/fitimage-sign.inc
@@ -0,0 +1,14 @@
+inherit uboot-sign
+
+UBOOT_SIGN_ENABLE = "0"
+UBOOT_SIGN_KEYDIR = "${COREBASE}/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-gxp/"
+UBOOT_SIGN_KEYNAME = "dev"
+FIT_HASH_ALG = "sha512"
+UBOOT_FIT_HASH_ALG = "sha512"
+
+concat_dtb_helper:append() {
+ if [ -e "${DEPLOYDIR}/${UBOOT_NODTB_IMAGE}" -a -e "$deployed_uboot_dtb_binary" ]; then
+ cd ${DEPLOYDIR}
+ cat ${UBOOT_NODTB_IMAGE} $deployed_uboot_dtb_binary | tee ${B}/${UBOOT_BINARY} > ${UBOOT_IMAGE}
+ fi
+}
diff --git a/meta-hpe/meta-gxp/conf/machine/include/gxp.inc b/meta-hpe/meta-gxp/conf/machine/include/gxp.inc
index 8f515d99a..e31814556 100644
--- a/meta-hpe/meta-gxp/conf/machine/include/gxp.inc
+++ b/meta-hpe/meta-gxp/conf/machine/include/gxp.inc
@@ -15,8 +15,8 @@ MACHINEOVERRIDES .= ":gxp"
DEFAULTTUNE ?= "armv6-novfp"
require conf/machine/include/arm/arch-armv6.inc
-UBOOT_MACHINE = "gxp_defconfig"
-UBOOT_ENTRYPOINT = "0x40100000"
-UBOOT_LOADADDRESS = "0x40100000"
+UBOOT_MACHINE ?= "gxp_defconfig"
+UBOOT_ENTRYPOINT ?= "0x40100000"
+UBOOT_LOADADDRESS ?= "0x40100000"
diff --git a/meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc b/meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc
index 016d9c675..747e7763e 100644
--- a/meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc
+++ b/meta-hpe/meta-gxp/conf/machine/include/hpe_soc.inc
@@ -2,5 +2,5 @@ PREFERRED_PROVIDER_virtual/kernel ?= "linux-obmc"
PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-gxp"
PREFERRED_PROVIDER_u-boot ?= "u-boot-gxp"
-//PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-gxp"
+PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-gxp"
diff --git a/meta-hpe/meta-gxp/recipes-bsp/image/files/header-512.sig b/meta-hpe/meta-gxp/recipes-bsp/image/files/header-512.sig
new file mode 100644
index 000000000..818bd6f74
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-bsp/image/files/header-512.sig
Binary files differ
diff --git a/meta-hpe/meta-gxp/recipes-bsp/image/files/header.sig b/meta-hpe/meta-gxp/recipes-bsp/image/files/header.sig
new file mode 100644
index 000000000..765375d02
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-bsp/image/files/header.sig
Binary files differ
diff --git a/meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb b/meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb
index 969937551..d8bcc5428 100644
--- a/meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb
+++ b/meta-hpe/meta-gxp/recipes-bsp/image/gxp-bootblock.bb
@@ -1 +1 @@
-inherit gxp-bootblock-n-poc
+inherit gxp-bootblock-n
diff --git a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2019.07.inc b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2020.10.inc
index 13cd7b42a..2efeb9e09 100644
--- a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2019.07.inc
+++ b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-common-gxp_2020.10.inc
@@ -1,4 +1,4 @@
-HOMEPAGE = "https://www.github.com/HewlettPackard/gxp-uboot"
+HOMEPAGE = "https://github.com/HewlettPackard/gxp-uboot"
DEPENDS += "flex-native bison-native bc-native"
LICENSE = "GPLv2+"
@@ -7,10 +7,10 @@ PE = "1"
# We use the revision in order to avoid having to fetch it from the
# repo during parse
-SRCREV = "e15b2ace2d7f38d470ba3b0415d47e05281c7660"
-UBRANCH = "v2019.07-gxp-openbmc"
+SRCREV = "b139a8a9e6e89e4115741498d454847d99239eda"
+UBRANCH = "v2020.10-gxp-openbmc"
SRC_URI = "git://github.com/HewlettPackard/gxp-uboot.git;branch=${UBRANCH}"
S = "${WORKDIR}/git"
-PV = "v2019.07+git${SRCPV}"
+PV = "v2020.10+git${SRCPV}"
diff --git a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp/alt_fw_env.config b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp/alt_fw_env.config
new file mode 100644
index 000000000..3d85f9974
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp/alt_fw_env.config
@@ -0,0 +1,25 @@
+# Configuration file for fw_(printenv/setenv) utility.
+# Up to two entries are valid, in this case the redundant
+# environment sector is assumed present.
+# Notice, that the "Number of sectors" is ignored on NOR and SPI-dataflash.
+# Furthermore, if the Flash sector size is omitted, this value is assumed to
+# be the same as the Environment size, which is valid for NOR and SPI-dataflash
+
+# NOR example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd1 0x0000 0x20000 0x20000
+#/dev/mtd2 0x0000 0x4000 0x4000
+
+# MTD SPI-dataflash example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd2 0x00000 0x20000
+/dev/mtd/alt-u-boot-env 0x00000 0x10000
+/dev/mtd/alt-u-boot-env 0x10000 0x10000
+#/dev/mtd5 0x4200 0x4200
+#/dev/mtd6 0x4200 0x4200
+
+# NAND example
+#/dev/mtd0 0x4000 0x4000 0x20000 2
+
+# Block device example
+#/dev/mmcblk0 0xc0000 0x20000
diff --git a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp/fw_env.config b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp/fw_env.config
new file mode 100644
index 000000000..19ace4b88
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp/fw_env.config
@@ -0,0 +1,25 @@
+# Configuration file for fw_(printenv/setenv) utility.
+# Up to two entries are valid, in this case the redundant
+# environment sector is assumed present.
+# Notice, that the "Number of sectors" is ignored on NOR and SPI-dataflash.
+# Furthermore, if the Flash sector size is omitted, this value is assumed to
+# be the same as the Environment size, which is valid for NOR and SPI-dataflash
+
+# NOR example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd1 0x0000 0x20000 0x20000
+#/dev/mtd2 0x0000 0x4000 0x4000
+
+# MTD SPI-dataflash example
+# MTD device name Device offset Env. size Flash sector size Number of sectors
+#/dev/mtd2 0x00000 0x20000
+/dev/mtd/u-boot-env 0x00000 0x10000
+/dev/mtd/u-boot-env 0x10000 0x10000
+#/dev/mtd5 0x4200 0x4200
+#/dev/mtd6 0x4200 0x4200
+
+# NAND example
+#/dev/mtd0 0x4000 0x4000 0x20000 2
+
+# Block device example
+#/dev/mmcblk0 0xc0000 0x20000
diff --git a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb
new file mode 100644
index 000000000..daf5a2cde
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-fw-utils-gxp_2020.10.bb
@@ -0,0 +1,46 @@
+require u-boot-common-gxp_2020.10.inc
+
+SRC_URI += "file://fw_env.config"
+SRC_URI += "file://alt_fw_env.config"
+
+# FIXME - Get fw_printenv/fw_setenv tool
+UBOOT_MACHINE ?= "gxp_defconfig"
+
+SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
+DEPENDS += "mtd-utils"
+
+PROVIDES += "u-boot-fw-utils"
+
+INSANE_SKIP:${PN} = "already-stripped"
+EXTRA_OEMAKE:class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
+EXTRA_OEMAKE:class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake envtools
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ ln -sf fw_printenv ${D}${base_sbindir}/fw_setenv
+
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 644 ${WORKDIR}/alt_fw_env.config ${D}${sysconfdir}/alt_fw_env.config
+}
+
+do_install:class-cross () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ ln -sf fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_DIRS:append:class-cross = " ${bindir_cross}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+BBCLASSEXTEND = "cross"
+
+RDEPENDS:${PN} = "udev-gxp-mtd-partitions"
diff --git a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-gxp_2019.07.bb b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-gxp_2020.10.bb
index 58a65b398..92e1975f9 100644
--- a/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-gxp_2019.07.bb
+++ b/meta-hpe/meta-gxp/recipes-bsp/u-boot/u-boot-gxp_2020.10.bb
@@ -1,6 +1,7 @@
require recipes-bsp/u-boot/u-boot-common.inc
require recipes-bsp/u-boot/u-boot.inc
-require u-boot-common-gxp_2019.07.inc
+require u-boot-common-gxp_2020.10.inc
+require conf/machine/include/fitimage-sign.inc
S = "${WORKDIR}/git"
diff --git a/meta-hpe/meta-gxp/recipes-connectivity/jsnbd/jsnbd/state_hook b/meta-hpe/meta-gxp/recipes-connectivity/jsnbd/jsnbd/state_hook
new file mode 100755
index 000000000..f28326339
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-connectivity/jsnbd/jsnbd/state_hook
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+if [ $# -ne 2 ]
+then
+ echo "usage: $0 <start|stop> <config>" >&2
+ exit 1
+fi
+
+action=$1
+config=$2
+
+gadget_name=mass-storage
+gadget_dir=/sys/kernel/config/usb_gadget/$gadget_name
+
+case "$config" in
+0)
+ nbd_device=/dev/nbd0
+ ;;
+*)
+ echo "invalid config $config" >&2
+ exit 1
+ ;;
+esac
+
+set -ex
+
+case "$action" in
+start)
+ mkdir -p $gadget_dir
+ (
+ cd $gadget_dir
+ # http://www.linux-usb.org/usb.ids
+ # |-> 1d6b Linux Foundation
+ # |-> 0104 Multifunction Composite Gadget
+ echo "0x1d6b" > idVendor
+ echo "0x0104" > idProduct
+ mkdir -p strings/0x409
+ echo "OpenBMC" > strings/0x409/manufacturer
+ echo "Virtual Media Device" > strings/0x409/product
+ mkdir -p configs/c.1/strings/0x409
+ echo "config 1" > configs/c.1/strings/0x409/configuration
+ mkdir -p functions/mass_storage.usb0
+ ln -s functions/mass_storage.usb0 configs/c.1
+ echo 1 > functions/mass_storage.usb0/lun.0/removable
+ echo 1 > functions/mass_storage.usb0/lun.0/ro
+ echo 0 > functions/mass_storage.usb0/lun.0/cdrom
+ echo $nbd_device > functions/mass_storage.usb0/lun.0/file
+ echo "80402000.udc" > UDC
+ )
+ ;;
+stop)
+ (
+ cd $gadget_dir
+ echo "" > UDC
+ rm configs/c.1/mass_storage.usb0
+ rmdir functions/mass_storage.usb0
+ rmdir configs/c.1/strings/0x409
+ rmdir configs/c.1
+ rmdir strings/0x409
+ )
+ rmdir $gadget_dir
+ ;;
+*)
+ echo "invalid action $action" >&2
+ exit 1
+esac
+
+exit 0
+
diff --git a/meta-hpe/meta-gxp/recipes-connectivity/jsnbd/jsnbd_git.bbappend b/meta-hpe/meta-gxp/recipes-connectivity/jsnbd/jsnbd_git.bbappend
new file mode 100644
index 000000000..1061a9271
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-connectivity/jsnbd/jsnbd_git.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+FILES:${PN} += "${sysconfdir}/nbd-proxy/state"
+SRC_URI += "file://state_hook"
+
+do_install:append() {
+ install -d ${D}${sysconfdir}/nbd-proxy/
+ install -m 0755 ${WORKDIR}/state_hook ${D}${sysconfdir}/nbd-proxy/state
+}
diff --git a/meta-hpe/meta-gxp/recipes-core/busybox/busybox/FEATURE_FANCY_HEAD.cfg b/meta-hpe/meta-gxp/recipes-core/busybox/busybox/FEATURE_FANCY_HEAD.cfg
new file mode 100644
index 000000000..16017ea48
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-core/busybox/busybox/FEATURE_FANCY_HEAD.cfg
@@ -0,0 +1 @@
+CONFIG_FEATURE_FANCY_HEAD=y
diff --git a/meta-hpe/meta-gxp/recipes-core/busybox/busybox_%.bbappend b/meta-hpe/meta-gxp/recipes-core/busybox/busybox_%.bbappend
new file mode 100644
index 000000000..a1d63848f
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-core/busybox/busybox_%.bbappend
@@ -0,0 +1,2 @@
+SRC_URI += "file://FEATURE_FANCY_HEAD.cfg"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb b/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
index dc185655b..4321a39de 100644
--- a/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
+++ b/meta-hpe/meta-gxp/recipes-core/udev/udev-gxp-mtd-partitions.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
S = "${WORKDIR}"
SRC_URI += "file://76-gxp-mtd-partitions.rules"
-RDEPENDS_${PN} += "udev"
+RDEPENDS:${PN} += "udev"
do_install() {
- install -d ${D}/${base_libdir}/udev/rules.d
- install -m 0644 ${WORKDIR}/76-gxp-mtd-partitions.rules ${D}/${base_libdir}/udev/rules.d
+ install -d ${D}/${nonarch_base_libdir}/udev/rules.d
+ install -m 0644 ${WORKDIR}/76-gxp-mtd-partitions.rules ${D}/${nonarch_base_libdir}/udev/rules.d
}
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
index 40de352f3..5d79797f7 100644
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc.inc
@@ -10,7 +10,7 @@ KSRC ?= "git://github.com/HewlettPackard/gxp-linux.git;branch=${KBRANCH}"
SRC_URI = "${KSRC}"
SRC_URI += " file://defconfig"
-FILESEXTRAPATHS_prepend_linux-obmc := "${THISDIR}/linux-obmc:"
+FILESEXTRAPATHS:prepend_linux-obmc := "${THISDIR}/linux-obmc:"
LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
@@ -21,3 +21,4 @@ require recipes-kernel/linux/linux-yocto.inc
# From 4.16+ the COPYING file changed
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
index 1507daf83..cdd03e3f7 100644
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc/defconfig
@@ -26,8 +26,6 @@ CONFIG_ARCH_HPE=y
CONFIG_ARCH_HPE_GXP=y
CONFIG_SECCOMP=y
# CONFIG_ATAGS is not set
-CONFIG_ZBOOT_ROM_TEXT=0x0
-CONFIG_ZBOOT_ROM_BSS=0x0
# CONFIG_SUSPEND is not set
CONFIG_ARM_CRYPTO=y
CONFIG_CRYPTO_SHA1_ARM=y
@@ -37,8 +35,6 @@ CONFIG_CRYPTO_AES_ARM=y
CONFIG_CRYPTO_CHACHA20_NEON=y
CONFIG_CRYPTO_POLY1305_ARM=y
CONFIG_JUMP_LABEL=y
-# CONFIG_STRICT_KERNEL_RWX is not set
-# CONFIG_BLK_DEBUG_FS is not set
# CONFIG_CORE_DUMP_DEFAULT_ELF_HEADERS is not set
CONFIG_KSM=y
CONFIG_CLEANCACHE=y
@@ -50,12 +46,22 @@ CONFIG_UNIX_DIAG=y
CONFIG_XFRM_USER=y
CONFIG_XFRM_STATISTICS=y
CONFIG_INET=y
+CONFIG_IP_ADVANCED_ROUTER=y
+CONFIG_IP_MULTIPLE_TABLES=y
+CONFIG_IP_ROUTE_MULTIPATH=y
+CONFIG_IP_ROUTE_VERBOSE=y
+CONFIG_IP_PNP=y
+CONFIG_IP_PNP_DHCP=y
+CONFIG_IP_PNP_BOOTP=y
CONFIG_IPV6_ROUTER_PREF=y
CONFIG_IPV6_ROUTE_INFO=y
+CONFIG_IPV6_OPTIMISTIC_DAD=y
# CONFIG_IPV6_SIT is not set
+CONFIG_IPV6_MULTIPLE_TABLES=y
CONFIG_BPFILTER=y
CONFIG_VLAN_8021Q=y
CONFIG_NETLINK_DIAG=y
+CONFIG_NET_NCSI=y
# CONFIG_WIRELESS is not set
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
@@ -114,7 +120,7 @@ CONFIG_NETDEVICES=y
# CONFIG_NET_VENDOR_VIA is not set
# CONFIG_NET_VENDOR_WIZNET is not set
# CONFIG_NET_VENDOR_XILINX is not set
-CONFIG_UMAC=y
+CONFIG_GXP_UMAC=y
# CONFIG_USB_NET_DRIVERS is not set
# CONFIG_WLAN is not set
# CONFIG_INPUT_LEDS is not set
@@ -140,16 +146,20 @@ CONFIG_IPMI_DEVICE_INTERFACE=y
CONFIG_IPMI_SI=y
CONFIG_IPMI_SSIF=y
CONFIG_HPE_KCS_IPMI_BMC=y
+CONFIG_IPMB_DEVICE_INTERFACE=y
CONFIG_HW_RANDOM_TIMERIOMEM=y
CONFIG_I2C_CHARDEV=y
CONFIG_I2C_GXP=y
CONFIG_I2C_SLAVE=y
CONFIG_I2C_SLAVE_EEPROM=y
-CONFIG_I2C_SLAVE_MQUEUE=y
CONFIG_SPI=y
CONFIG_GPIOLIB=y
CONFIG_GPIO_SYSFS=y
+CONFIG_GPIO_GXP_XREG=y
CONFIG_GPIO_GXP=y
+CONFIG_SENSORS_PECI_CPUTEMP=y
+CONFIG_SENSORS_PECI_DIMMTEMP=y
+CONFIG_SENSORS_SBTSI=y
CONFIG_SENSORS_EMC1403=y
CONFIG_SENSORS_GXP_FAN_CTRL=y
CONFIG_SENSORS_GXP_CORETEMP=y
@@ -205,12 +215,17 @@ CONFIG_HPE_GXP_XREG=y
CONFIG_HPE_GXP_FN2=y
CONFIG_HPE_GXP_CSM=y
CONFIG_HPE_GXP_SROM=y
+CONFIG_HPE_GXP_CHIF=y
CONFIG_PECI=y
CONFIG_PECI_CHARDEV=y
+CONFIG_PECI_GXP=y
CONFIG_FANOTIFY=y
CONFIG_AUTOFS_FS=y
CONFIG_OVERLAY_FS=y
CONFIG_OVERLAY_FS_REDIRECT_DIR=y
+CONFIG_VFAT_FS=y
+CONFIG_FAT_DEFAULT_UTF8=y
+CONFIG_EXFAT_FS=y
CONFIG_TMPFS=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_JFFS2_FS=y
@@ -235,6 +250,7 @@ CONFIG_CRYPTO_ARC4=y
CONFIG_CRYPTO_DEFLATE=y
CONFIG_CRYPTO_LZO=y
CONFIG_CRYPTO_ZSTD=y
+CONFIG_CRYPTO_ANSI_CPRNG=y
CONFIG_CRYPTO_USER_API_HASH=y
# CONFIG_CRYPTO_HW is not set
CONFIG_CRC16=y
@@ -249,10 +265,9 @@ CONFIG_DEBUG_INFO=y
# CONFIG_ENABLE_MUST_CHECK is not set
CONFIG_MAGIC_SYSRQ=y
CONFIG_PANIC_ON_OOPS=y
-CONFIG_SCHED_TRACER=y
-CONFIG_STACK_TRACER=y
CONFIG_FUNCTION_PROFILER=y
-CONFIG_TEST_KSTRTOX=y
+CONFIG_STACK_TRACER=y
+CONFIG_SCHED_TRACER=y
CONFIG_STRICT_DEVMEM=y
CONFIG_DEBUG_USER=y
CONFIG_DEBUG_LL=y
@@ -261,4 +276,4 @@ CONFIG_DEBUG_UART_PHYS=0xC00000F0
CONFIG_DEBUG_UART_VIRT=0xF00000F0
CONFIG_DEBUG_UART_8250_SHIFT=0
CONFIG_EARLY_PRINTK=y
-CONFIG_UNWINDER_FRAME_POINTER=y
+CONFIG_TEST_KSTRTOX=y
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb
new file mode 100644
index 000000000..d0b5407ae
--- /dev/null
+++ b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.10.bb
@@ -0,0 +1,10 @@
+KBRANCH ?= "dev-5.10-gxp-openbmc"
+LINUX_VERSION ?= "5.10.17"
+SRCREV="8d942b456304d3a21597cda47387a45ace61a225"
+
+require linux-obmc.inc
+require conf/machine/include/fitimage-sign.inc
+
+# OpenBMC loads in kernel features via other mechanisms so this check
+# in the kernel-yocto.bbclass is not required
+#KERNEL_DANGLING_FEATURES_WARN_ONLY="1"
diff --git a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.7.bb b/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.7.bb
deleted file mode 100644
index 0e57afd87..000000000
--- a/meta-hpe/meta-gxp/recipes-kernel/linux/linux-obmc_5.7.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-KBRANCH ?= "dev-5.7-gxp-openbmc"
-LINUX_VERSION ?= "5.7.10"
-
-SRCREV="1ca49db2b4baf304d29396a603d0308770797a5c"
-require linux-obmc.inc
-
-# OpenBMC loads in kernel features via other mechanisms so this check
-# in the kernel-yocto.bbclass is not required
-KERNEL_DANGLING_FEATURES_WARN_ONLY="1"