summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-palmetto/recipes-phosphor/inventory/inventory-cleanup.bb
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2020-01-16 10:16:21 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-17 21:24:14 +0300
commit77b79467082d25cba946736f568b93072ecf4822 (patch)
tree71cb1a7e1471421fa7ff67253dee78fc35218666 /meta-ibm/meta-palmetto/recipes-phosphor/inventory/inventory-cleanup.bb
parent11ba51674f0e884f5b9a45a90a5310319889e813 (diff)
downloadopenbmc-77b79467082d25cba946736f568b93072ecf4822.tar.xz
meta-palmetto: Add inventory-cleanup.yaml
The yaml add the "xyz.openbmc_project.Inventory.Item.Chassis" interface to "/xyz/openbmc_project/inventory/system/chassis" object. This is needed for bmcweb to correctly get the chassis id in /redfish/v1/Chassis/. Tested: Verify that /redfish/v1/Chassis/chassis exists on Palmetto with this change. It was 404 without this change. (From meta-ibm rev: 5930fdcc620b5ab65418b748b3cc0db465dc05fb) Signed-off-by: Lei YU <mine260309@gmail.com> Change-Id: I67d5458d4540feacc67bd558dabb642b377f508b Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-palmetto/recipes-phosphor/inventory/inventory-cleanup.bb')
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/inventory/inventory-cleanup.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ibm/meta-palmetto/recipes-phosphor/inventory/inventory-cleanup.bb
new file mode 100644
index 000000000..0c4b56f72
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Copy the inventory cleanup yaml for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+S = "${WORKDIR}"
+
+SRC_URI = "file://inventory-cleanup.yaml"
+
+do_install() {
+ install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
+}
+
+FILES_${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"