summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-palmetto
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2019-04-26 11:49:59 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-26 16:38:59 +0300
commit78e27db36facd3baa15f4efcb59678c04ef7df21 (patch)
treec2df22d161f8452afed8757db7bd8dc11924146d /meta-ibm/meta-palmetto
parent62e0188468af0430cb06e1fb5a2daaaa21c9ae12 (diff)
downloadopenbmc-78e27db36facd3baa15f4efcb59678c04ef7df21.tar.xz
meta-palmetto: add occ-control-config-native
openpower-occ-control requires a sensor header file generated from occ_sensor.yaml. By default it uses an example yaml, which does not fit for Palmetto. Add palmetto-occ-control-config-native.bb to use its own occ_sensor.yaml, so that the package uses the correct config. Tested: Verify the build uses the correct config generated from palmetto's occ_sensor.yaml. (From meta-ibm rev: 12a660de3fff453e2f24ee2cc98b387fa7b8c541) Signed-off-by: Lei YU <mine260309@gmail.com> Change-Id: Ifbf6ffb0c69e6d827410b8370c6481bb953d10d0 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-palmetto')
-rw-r--r--meta-ibm/meta-palmetto/conf/machine/palmetto.conf1
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/occ/files/occ_sensor.yaml3
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/occ/palmetto-occ-control-config-native.bb18
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-ibm/meta-palmetto/conf/machine/palmetto.conf b/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
index 1ba200013..ef5d957b5 100644
--- a/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
+++ b/meta-ibm/meta-palmetto/conf/machine/palmetto.conf
@@ -20,3 +20,4 @@ PHOSPHOR_MRW_REV = "82818682f2c2009c30d700df6d5f8897a3096e4f"
PREFERRED_PROVIDER_virtual/obmc-inventory-data = "obmc-inventory"
PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-inventory = "palmetto-ipmi-inventory-map-native"
PREFERRED_PROVIDER_virtual/phosphor-led-manager-config-native = "palmetto-led-manager-config-native"
+PREFERRED_PROVIDER_virtual/openpower-occ-control-config-native = "palmetto-occ-control-config-native"
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/occ/files/occ_sensor.yaml b/meta-ibm/meta-palmetto/recipes-phosphor/occ/files/occ_sensor.yaml
new file mode 100644
index 000000000..844779678
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/occ/files/occ_sensor.yaml
@@ -0,0 +1,3 @@
+- Instance: 0
+ SensorID: 0x08
+ SensorName: occ0
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/occ/palmetto-occ-control-config-native.bb b/meta-ibm/meta-palmetto/recipes-phosphor/occ/palmetto-occ-control-config-native.bb
new file mode 100644
index 000000000..609c8437f
--- /dev/null
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/occ/palmetto-occ-control-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Palmetto OCC Control sensor IDs"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit openpower-occ-control
+
+SRC_URI += "file://occ_sensor.yaml"
+
+PROVIDES += "virtual/openpower-occ-control-config-native"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${YAML_DEST}/
+ install -D occ_sensor.yaml ${YAML_DEST}/occ_sensor.yaml
+}